1

I would like to stop hyperref from creating bookmarks for a KOMA-Script document. The option bookmarks=false does not work with KOMA classes, it works flawlessly with default classes such as report. Is there any way to disable PDF bookmarks in KOMA-Script documents with the hyperref package.

MWE:

\documentclass{scrreprt}
\usepackage[bookmarks=false]{hyperref}
\begin{document}
    \tableofcontents
    \chapter{Chapter}    
    \section{Section}
\end{document}
1

KOMA Script loads the bookmark package by default, which overrides hyperref's option. You can disable this with the (apparently undocumented) document class option bookmarkpackage=false.

  • is there something we could easily do in hyperref to make the boolean option work here? – David Carlisle Sep 8 at 23:20
  • @DavidCarlisle After some investigation I found the root of the problem (automatic loading of the bookmark package). I don't think any modifications are in order (except maybe to the KOMA Script documentation). Maybe a warning would be nice, if hyperref's bookmarks=false is used together with bookmark. – schtandard Sep 8 at 23:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.