System: Windows 10, MikTeX 2.9, WinEdt 10.2

Workflow: tex -> ps -> pdf

Problem: I created a file named "TeoriaTehtäviä.tex" containing two characters outside the 7 bit ASCII range. Here's what happened:

  • LaTeX (run within WinEdt) runs without any problems.
  • The built-in program "dvips" (IIRC comes with MikTeX) has no problems whatsoever creating a corresponding file "TeoriaTehtäviä.ps". I can view that just fine with GSView.
  • But, the attempt to convert this to pdf by clicking the "ps2pdf" button (IIRC another program that came with MikTeX) gives the error message: Error: /undefinedfilename in (TeoriaTehtvi.ps). This is in a sense not a surprise because no file with such name exists.

The problem is obviously with the characters that fall outside the range of 7-bit ASCII. We have related posts such as this. And I can solve my problem just fine by using another file name. But, I still have the questions:

  • Is there a fix to this problem?
  • Why is this not a problem for "dvips", but "ps2pdf" acts up? In other words, why different component programs of MikTeX behave differently?

I'm afraid I also somewhat miffed that even in 2019 it is still possible to run into problems like this :-(.


  • A per suggestion from AlexG, I tested it within Windows PowerShell. I got the exact same error message.
  • I also tried calling mgs.exe TeoriaTehtäviä.ps TeoriaTehtäviä.pdf (mgs is a version of Ghostscript that came with MikTeX) within Windows PowerShell. In the command prompt the error message changed slightly to read Error: /undefinedfilename in (TeoriaTeht\303\244vi\303\244.pdf). In other words, instead of dropping the characters they were substituted by their extended codes.
  • 1
    This is operating-system related. In my case, a unicode-enabled Linux system, there is no problem converting a PS file with umlauts (äöüß) in the file name to PDF using ps2pdf in a terminal.
    – AlexG
    Sep 12 '19 at 11:02
  • Thanks for testing this @AlexG. Much appreciated. That still does not explain why dvips and ps2pdf behave differently. Scratches head :-) Sep 12 '19 at 11:06
  • 2
    You invoke all programs from within your editor. Did you try running them on the command line (cmd.exeor PowerShell)? Maybe it is only an editor (WinEdit) problem.
    – AlexG
    Sep 12 '19 at 11:11
  • I would suggest a bug report in the miktex issue tracker. In texlive it works, and mgs itself seems to work too, so it is perhaps a problem in the ps2pdf and follow up scripts. Sep 12 '19 at 12:10
  • Thanks for the suggestion @AlexG. I tested it within Windows PowerShell(x86). The error message was the same. Wonder whether some command line options would help? This makes it sound like it is not a problem caused by WinEdt. Sep 12 '19 at 12:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.