1

I am taking the format/idea from enter link description here

Chapter title: enter image description here

Book title: enter image description here

My format is:

The reference taken from here: enter link description here

@incollection{deborah123,
  author      = "Deborah Lewis and Marie O'Boyle-Duggan and Susan Poultney",
  title       = "Communication skills education and training in pre-registeration BSc Nursing",
  editor      = "David W. Kissane and Barry D. Bultz and Phyllis N. Butow and Carma L. Bylund and Simon Noble and Susie Wilkinson",
  booktitle   = "Oxford Textbook of Communication in Oncology and Palliative Care",
  publisher   = "Oxford University Press",
  address     = "Oxford",
  year        = 2017,
  pages       = "149-154",
  Edition = "2nd edn"
}

Output:

enter image description here

However, I want the output to be where the book author came first, then only book title as shown below:

enter image description here

Lewis, D., O'Boyle-Duggan, M. and Poultney, S. (2017) Communication skills education and training in pre-registration BSc Nursing. In: D. W. Kissane, B. D. Bultz, P. N. Butow, C. L. Bylund, S. Noble and S. Wilkinson, eds. Oxford Textbook of Communication in Oncology and Palliative Care. 2nd edn. Oxford: Oxford University Press, pp. 149-154.

My full MWE:

\RequirePackage{filecontents}
\begin{filecontents}{\jobname.bib}

@incollection{deborah123,
  author      = "Deborah Lewis and Marie O'Boyle-Duggan and Susan Poultney",
  title       = "Communication skills education and training in pre-registeration BSc Nursing",
  editor      = "David W. Kissane and Barry D. Bultz and Phyllis N. Butow and Carma L. Bylund and Simon Noble and Susie Wilkinson",
  booktitle   = "Oxford Textbook of Communication in Oncology and Palliative Care",
  publisher   = "Oxford University Press",
  address     = "Oxford",
  year        = 2017,
  pages       = "149-154",
  Edition = "2nd edn"
}


\end{filecontents}


\documentclass[british]{article}

\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{babel}

\usepackage{csquotes}


\usepackage[backend=biber, 
% style=authoryear, 
 style=authoryear-comp,
% citestyle=authoryear, 
dashed=false,
maxcitenames=2,
maxbibnames=99,
giveninits,
uniquename=init]{biblatex}

\addbibresource{\jobname.bib} % \jobname to use the bib file created with filecontents

\DeclareNameAlias{sortname}{family-given}
\DeclareDelimFormat{nameyeardelim}{\addcomma\space}

\usepackage[unicode,colorlinks,citecolor=blue]{hyperref}
% \renewcommand*{\nameyeardelim}{\addcomma\space}



\renewcommand{\compcitedelim}{\space\&\space}


\begin{document}


A book is done \parencite{deborah123}.



\printbibliography
\end{document}
3

I suggest you use the ext-authoryear-comp style, which has an option to do this. ext-authoryear-comp is a drop in replacement for authoryear-comp but with extra features. The option is called innamebeforetitle. See the biblatex-ext manual for details.

Also, rather than putting edition = {2nd edn} in your bib file, you should just use edition = {2} and change the string for edition, like this:

\DefineBibliographyStrings{british}{%
  edition = {edn},
}

MWE

\RequirePackage{filecontents}
\begin{filecontents}{\jobname.bib}
@incollection{deborah123,
  author      = "Deborah Lewis and Marie O'Boyle-Duggan and Susan Poultney",
  title       = "Communication skills education and training in pre-registeration BSc Nursing",
  editor      = "David W. Kissane and Barry D. Bultz and Phyllis N. Butow and Carma L. Bylund and Simon Noble and Susie Wilkinson",
  booktitle   = "Oxford Textbook of Communication in Oncology and Palliative Care",
  publisher   = "Oxford University Press",
  address     = "Oxford",
  year        = 2017,
  pages       = "149-154",
  edition     = "2"
}
\end{filecontents}

\documentclass[british]{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{babel}
\usepackage{csquotes}
\usepackage[backend=biber, 
  style=ext-authoryear-comp,
  innamebeforetitle,
  dashed=false,
  maxcitenames=2,
  maxbibnames=99,
  giveninits,
  uniquename=init]{biblatex}
\addbibresource{\jobname.bib}

\DeclareNameAlias{sortname}{family-given}
\DeclareDelimFormat{nameyeardelim}{\addcomma\space}
\usepackage[unicode,colorlinks,citecolor=blue]{hyperref}
\renewcommand{\compcitedelim}{\space\&\space}

\DefineBibliographyStrings{british}{%
  edition = {edn},
}

\begin{document}
A book is done \autocite{deborah123}.
\printbibliography
\end{document}

MWE output

  • Thanks. I try run it, but not the output as your screenshot. It only shown A book is done deborah123. Another error it said Package bibilatex error: Style ext-authoryear-comp not found. I am using Overleaf to run it – aan Sep 17 at 8:05
  • @aan, presumably Overleaf does not have biblatex-ext as it's version of TeXLive is too old. – David Purton Sep 17 at 8:33
  • 1
    @aan, there are some other options at tex.stackexchange.com/questions/173638/…. In fact this question should probably be a duplicate. – David Purton Sep 17 at 8:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.