-1

I've got a document in REVTex (based off the apssample.tex template) that is exhibiting some odd behavior in the bibliography: For papers with two authors, the space between the first author's last name and "and" is missing, so that

J. Smith and M. Jones

is rendered as

J. Smithand M. Jones

If I switch the document from REVTex 4.2 to REVTex 4.1, then the bibliography renders as expected.

I haven't been able to track down this problem any more deeply -- e.g., the console output doesn't suggest anything obvious -- and my internet searches haven't turned up any other reports on this behavior.

Any suggestions on what I might be missing?

8
  • 2
    The problem is a bit difficult to reproduce at the moment. Where did you find the template, could you minimize that file and post it here? Just remove everything that is not related to the issue.
    – Marijn
    Commented Sep 17, 2019 at 21:19
  • 1
    @Marijn While trying to set up a minimal example, I've tracked the problem down to a specific one-line change in the APS revtex bst file from version 4.1 to 4.2; I'm surprised that this hasn't caused wider problems and will contact the author of the file to find out why the change was made.
    – RLH
    Commented Sep 17, 2019 at 22:43
  • 1
    Why was this question closed? It seems to me that the right course of action for improving this question would be for me to post a self-answer based on my comment of having tracked down the wrong behavior to a change in REVTex’s bst file, but I can’t do that while the question is closed.
    – RLH
    Commented Apr 10, 2023 at 6:39
  • 2
    Comment in lieu of an answer until I can post one: I've just gone back to my emails with the REVTex team and searched through their SVN logs. The bug was fixed in tug.org/svn/texlive/trunk/Master/texmf-dist/bibtex/bst/revtex/… (specifically the change to line 1580), which had not propagated to the system I was using at the time of the question. I don't think it's worth my time at this point to build an MWE for a historical bug, when the answer is "Make sure you're using the up-to-date bst version".
    – RLH
    Commented Apr 10, 2023 at 15:18
  • 1
    I really don't understand the insistence on providing an MWE for a historical package-bug, where the relevant information for anyone reading this now is that: 1. Missing spaces are a problem that occurred in some versions of REVTex 4.2, and 2. The problem was acknowledged as a bug and has been fixed in recent versions.
    – RLH
    Commented Apr 16, 2023 at 16:35

1 Answer 1

1

The missing space was caused by a bug in apsrev4-2.bst. The bug was fixed in this update to the bst file (specifically the change to line 1580), which had not propagated to the system I was writing the paper on.

Not the answer you're looking for? Browse other questions tagged .