3

I have texlive installed on a debian-like host (linux mint) via apt. Now I would like to add a new texmf tree. What is the correct or recommended way to do it? I would like to keep this new texmf tree separate from existing texmf trees on the system. I did some searching on the topic, and the closest answer to my question is to run this command:

$ tlmgr conf texmf TEXMFHOME "~/texmf:~/another-texmf"

Indeed this works fine on macOS, however on Linux Mint 19.2 it doesn't. After running the command, the new value of TEXMFHOME is set in /usr/share/texlive/texmf.cnf:

$ tlmgr conf texmf TEXMFHOME "~/texmf:~/another-texmf"
(running on Debian, switching to user mode!)
setting texmf TEXMFHOME to ~/texmf:~/another-texmf (in /usr/share/texlive/texmf.cnf)

but that file seems not being used:

$ kpsewhich -var-value TEXMFHOME
/home/tony/texmf
$ kpsewhich -var-value TEXMFCNF
/etc/texmf/web2c:/usr/local/share/texmf/web2c:/usr/share/texlive/texmf-dist/web2c

There are several texmf.cnf files on my system:

/etc/texmf/web2c/texmf.cnf
/usr/share/texmf/web2c/texmf.cnf
/usr/share/texlive/texmf-dist/web2c/texmf.cnf
/usr/share/texlive/texmf.cnf

So it seems that /usr/share/texlive/texmf.cnf is not read, although it was created by tlmgr conf texmf

What am I missing here? Thanks in advance for any hint.

3

1 Answer 1

2

Solution for vanilla TeX Live

Looking at tlmgr help and searching for auxtrees there shows the possibility of doing (at least on vanilla TeXlive 2019, please check before using this command on your system):

sudo tlmgr conf auxtrees add /path/to/folder

The folder doesn't need a ls-R file (so doesn't need to be indexed), and in fact you shouldn't, so that changes to that folder become available immediately and you don't forget to update the index.

You can remove a folder added this way doing:

sudo tlmgr conf auxtrees remove /path/to/folder
4
  • tlmgr is disabled for system-operations on debian/ubuntu as it will conflict with apt.
    – Stewart
    Jan 31, 2022 at 14:52
  • @Stewart Then ask your distribution maintainers or a follow up question further narrowing your problem, the above works for vanilla TeX Live.
    – Skillmon
    Jan 31, 2022 at 18:55
  • Very true. But this answer will only help those with an upstream installation. OP is clearly running a Mint/Ubuntu/Debian release (see output of tlmgr). That release will not read the /usr/share/texlive/texmf.cnf created by the command you suggest.
    – Stewart
    Jan 31, 2022 at 19:06
  • @Stewart oh, you're right, sorry :) I'll edit the answer accordingly.
    – Skillmon
    Jan 31, 2022 at 19:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .