0

In the code below there are two line breaks between "test" and the the text below it. How do you make there be just one?

\documentclass[7pt]{article}
\usepackage{multicol}
\usepackage{lipsum}

\begin{document}
test
\begin{multicols}{2}\lipsum[2]\end{multicols}
\end{document}

text with unwanted automatic line break

  • That is.. technically correct. Though requires you to already know the spacing, may fail in weird situations, ect... a different question suggests using \\[-2\baselineskip] before \begin{multicols} which works but feels hack-y. A proper \nolinebreak option would be preferred, if such a thing exists. – Christopher Pratt Sep 22 at 21:36
  • 1
    The \multicolsep is added before and after the multicol environment in addition to the line spacing inserted by TeX. If you set \multicolsep to 0pt you will get no extra spacing; that is, it will be in the "next line". – Phelype Oleinik Sep 22 at 21:40
  • @PhelypeOleinik that's what I needed. Can you post a answer saying to use \setlength\multicolsep{0pt} at the top of the file or before the section in question so I can mark it as correct? – Christopher Pratt Sep 22 at 22:01

Browse other questions tagged or ask your own question.