0

How to make the title of the paper from:

NoiseSpeech, a noise of living bodies : towards Attali's "Composition"

to

NoiseSpeech, a noise of living bodies : towards Attali's 'Composition'

I am using:

  title={NoiseSpeech, a noise of living bodies: towards Attali's \mkbibquote{Composition}},

enter image description here

My MWE:

% \documentclass[12pt,oneside]{book}  % Remove draft option to show figures (for final draft), otherwise keep for faster production
\documentclass{article}
\usepackage{enumitem} % macros to modify appearance of 'itemize' environments

\usepackage{xpatch}

\usepackage[backend=biber, 
% style=authoryear, 
 style=authoryear-comp,
% citestyle=authoryear, 
dashed=false,
maxcitenames=2,
maxbibnames=99,
giveninits,
uniquename=init]{biblatex}


\DeclareNameAlias{sortname}{family-given} %for second and third author name

\renewcommand{\labelnamepunct}{\space} %to delete . after (1997)

\DeclareFieldFormat[article, incollection, unpublished]{title}{#1}

\DeclareFieldFormat*{title}{#1} %for conference title delete ".."
\DeclareFieldFormat[incollection]{title}{\mkbibemph{#1}} %for incollecion title italic ONLY
\DeclareFieldFormat[thesis]{title}{\mkbibemph{#1}} %for phdthesis title italic ONLY



\renewbibmacro{in:}{%
  \ifentrytype{article}{}{\printtext{\bibstring{in}\intitlepunct}}}



\newcommand*{\volnumdelim}{}
\DeclareFieldFormat[article,periodical]{number}{\mkbibparens{#1}}

\renewbibmacro*{volume+number+eid}{%
  \printfield{volume}%
  \setunit*{\volnumdelim}%
  \printfield{number}%
  \setunit{\addcomma\space}%
  \printfield{eid}}

\newcommand*{\jourvoldelim}{\addcomma\space}
\newcommand*{\jourserdelim}{\newunitpunct}
\newcommand*{\servoldelim}{\jourvoldelim}
\newcommand*{\volnumdatedelim}{\addspace}

\renewbibmacro*{journal+issuetitle}{%
  \usebibmacro{journal}%
  \setunit*{\jourvoldelim}%
  \iffieldundef{series}
    {}
    {\setunit*{\jourserdelim}%
     \printfield{series}%
     \setunit{\servoldelim}}%
  \usebibmacro{volume+number+eid}%
  \setunit{\volnumdatedelim}%
  \usebibmacro{issue+date}%
  \setunit{\addcolon\space}%
  \usebibmacro{issue}%
  \newunit}  
% to make volume (number), eg. 4(2)



% for delete comma after Author A and Aurhor b
\DefineBibliographyExtras{english}{%
   \let\finalandcomma\empty
   \let\finalandsemicolon\empty
 }

\renewcommand{\compcitedelim}{\addsemicolon\space}
\DeclareNameAlias{editorin}{given-family}

\newbibmacro*{byeditor:in}{%
  \ifnameundef{editor}
    {}
    {\printnames[editorin]{editor}%
     \setunit{\addcomma\space}%
     \usebibmacro{editorstrg}%
     \clearname{editor}}}     


\xpatchbibdriver{inbook}
  {\usebibmacro{in:}%
   \usebibmacro{bybookauthor}%
   \newunit\newblock
   \usebibmacro{maintitle+booktitle}%
   \newunit\newblock
   \usebibmacro{byeditor+others}}
  {\usebibmacro{in:}%
   \usebibmacro{bybookauthor}%
   \newunit\newblock
   \usebibmacro{byeditor:in}%
   \newunit\newblock
   \usebibmacro{maintitle+booktitle}%
   \newunit\newblock
   \usebibmacro{byeditor+others}}
  {}{}



% \usepackage{parskip}  

\usepackage[hypcap=false]{caption}

\usepackage{csquotes}

\usepackage[unicode,colorlinks,citecolor=blue]{hyperref}




\usepackage{filecontents}
\begin{filecontents*}{\jobname.bib}


@article{dean2005noisespeech,
  title={NoiseSpeech, a noise of living bodies: towards Attali's \mkbibquote{Composition}},
  author={Dean, Roger T},
  journal={NMEDIAC: Journal of New Media \& Culture},
  year={2005},
  number={1},
  volume={3}
}


\end{filecontents*}
\addbibresource{\jobname.bib}

\begin{document}
\nocite{*}


 in \textcite{dean2005noisespeech} 


\printbibliography
\end{document}
10
  • 2
    This depends on your babel language settings. What language are you using? American English uses double quotes (by default). British and Australian English uses single quotes. You can load the csquotes package and specify what style you want for outer and inner quote marks too. Sep 25, 2019 at 0:44
  • 2
    Oh! I see you are just using \usepackage[english]{babel}. You could specify \usepackage[british]{babel} and you will get single quotes everywhere at the outer level. But this may not be what you want and will also affect other things like date format. Sep 25, 2019 at 0:46
  • @DavidPurton. Thanks. If did not use \usepackage[british]{babel}. How can do a csquotes. In my MWE above, I do not have this \usepackage[british]{babel}
    – aan
    Sep 25, 2019 at 9:26
  • You could replace \usepackage{csquotes} with \usepackage[style=british]{csquotes}. Sep 26, 2019 at 0:18
  • 1
    The fact that you get the option clash means that you are loading it more than once with different options. Look for csquotes elsewhere in your code or included files. I do not get this error in your MWE and it successfully gives me only single quotes. Sep 27, 2019 at 0:19

1 Answer 1

2

There are a few different ways you can do this:

You can change your language to british (or australian) which uses single quotation marks for outer marks. i.e.,

\usepackage[british]{babel}
\usepackage{csquotes}
\usepackage{biblatex}

Bear in mind that this will also change other language related things like date formats.

The other option is to specify the quotation style directly with csquotes. i.e.,

\usepackage[english]{babel}
\usepackage[style=british]{csquotes}
\usepackage{biblatex}

This will use British style single quotation marks for outer quotation marks, but keep other language settings to babel's default for english (basically American English).

3

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .