1

This thread :

describes exactly my issue today. Thus, I tried the solution that was given, ie I added this in my preamble :

\usepackage{polyglossia}
\setdefaultlanguage{french}
\makeatletter
\XeTeXinterchartoks 4095 \french@punctthin = {\xpg@unskip\nobreak\thinspace}%
\XeTeXinterchartoks 4095 \french@punctthick = {\xpg@unskip\nobreakspace}%
\makeatother

The provided solution yields a wonerful error message :

xparse.sty | Error line 38 | Package xparse Error: Support package l3kernel too old.}
fontspec.sty | Error | Fatal fontspec error: "cannot-use-pdftex" The fontspec package requires either XeTeX or LuaTeX to function. You must change your typesetting engine to, e.g., "xelatex" or "lualatex" instead of plain "latex" or "pdflatex". For immediate help type H <return>.
xsparse.sty | Warning | You have requested, on input line 26, version `2017/04/01' of package expl3, but only version `2016/03/28 v6468 L3 programming layer (loader) ' is available.

So what I did is I tried to download and install/update the l3kernel thingy from :

It didn't do anything. Also, changing the compiler to either xelatex or lualatex didn't help much... I'm currently using pdflatex on a Windows 7 (x64) machine.

I'm so desperate, I cannot even update babel to its latest version, mpm tells me this :

> mpm --update=babel
(... a long while after ...)
mpm: The operation would not be completed because the following file failed verification:
mpm:
mpm: C:\Users\Anthony\_TeXPackageRepository\babel.tar.lzma

(I tried updating babel to pass a \usepackage[french]{babel} in my preamble.)

I manually install packages from a local repository (an issue I had a while ago made me have to use this solution, so I download .tar.lzma files from CTAN and I have set mpm --set-repository=C:\Users\Anthony\_TeXPackageRepository\. I'm not sure what's the issue here, because this method usually works for all other packages, either about installing them or updating them.

Does anyone know anything about this colon issue ? It seems like the thread I linked in the beginning is the only one tackling this issue, along with an apparently solved-issue Gith bug tracker :(

3
  • Welcome to TeX.SE.
    – Mico
    Sep 25, 2019 at 22:55
  • you should not have to get expl3 from ctan, it is part of every miktex or texlive installation and can be updated from the package manager also as the second error says you need to use xelatex not pdflatex for that document as \XeTeXinterchartok is a xetex-only command. Sep 25, 2019 at 23:03
  • To install from a local repository using mpm, I think it''s better to download from the CTAN MiKTeX repository [here](ftp.dante.de/pub/tex/systems/win32/miktex/tm/packages) for instance, not forgetting to download pr.ini, files.csv.lzma, miktex-zzdbi.tar.lzma (i=1,2,3).
    – Bernard
    Sep 25, 2019 at 23:10

1 Answer 1

1

In my opinion, the best solution consists of (a) performing a full re-installation of your MikTeX distribution (as you've discovered, trying to do a piece-meal update of a handful of packages is tedious and error-prone), (b) working with babel instead of polyglossia, and (c) not inserting spaces before : and ! in the input file. Just let LaTeX handle the chores of implementing details of French-style typography.

enter image description here

% !TEX TS-program = xelatex
\documentclass[12pt]{memoir}
\usepackage[french]{babel}

\begin{document}
Bonjour tout le monde. Si je vais au bout de la ligne, je vais avoir cela: non!
\end{document}

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .