1

I'm working with Overleaf (Online Latex Editor) and I have an issue with captions when I add a new figure. It generates automatically the figure number but it's bad written.

This is my code when I add a new figure:

\begin{figure}[h!]
    \centering
    \includegraphics[scale=0.29]{Git_Dashboard.PNG}
    \caption{Dashboard du projet Serious Game sur InnerSource}
\end{figure}

And this is the ouput:

Figure 1.: Dashboard du projet Serious Game sur InnerSource

I have Figure 1.: and I would like to get Figure 1: or just Figure 1.

How I can solve this issue ?

This is a minimal example:

\documentclass[]{interact}

\usepackage{epstopdf}% To incorporate .eps illustrations using PDFLaTeX, etc.
\usepackage{subfigure}% Support for small, `sub' figures and tables

\usepackage[numbers,sort&compress,merge]{natbib}% Citation support using natbib.sty
\bibpunct[, ]{(}{)}{,}{n}{,}{,}% Citation support using natbib.sty
\renewcommand\bibfont{\fontsize{10}{12}\selectfont}% Bibliography support using natbib.sty
\renewcommand\citenumfont[1]{\textit{#1}}% Citation numbers in italic font using natbib.sty
\renewcommand\bibnumfmt[1]{(#1)}% Parentheses enclose ref. numbers in list using natbib.sty

\theoremstyle{plain}% Theorem-like structures
\newtheorem{theorem}{Theorem}[section]
\newtheorem{lemma}[theorem]{Lemma}
\newtheorem{corollary}[theorem]{Corollary}
\newtheorem{proposition}[theorem]{Proposition}

\theoremstyle{definition}
\newtheorem{definition}[theorem]{Definition}
\newtheorem{example}[theorem]{Example}

\theoremstyle{remark}
\newtheorem{remark}{Remark}
\newtheorem{notation}{Notation}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[francais]{babel}
\usepackage{xcolor}
\usepackage{subfig}
\usepackage{listings}

\begin{document}

\begin{figure}[!ht]
    \centering
    \includegraphics[scale=0.29]{Git_Dashboard.PNG}
    \caption{Dashboard du projet Serious Game sur InnerSource}
\end{figure}

\end{document}
5
  • 2
    Could you please post a minimal compilable code reproducing your problem, not just a snippet?
    – Bernard
    Commented Sep 26, 2019 at 10:52
  • 2
    The answer may depend on your document class and the packages you load.
    – Bernard
    Commented Sep 26, 2019 at 10:59
  • 2
    Seems to be a problem with the "interact" documentclass. if this is compiled with the article class it works.
    – Sango
    Commented Sep 26, 2019 at 11:34
  • 2
    Is the interact document class available online somewhere?
    – Mico
    Commented Sep 26, 2019 at 13:48
  • Please make somehow available the interact class file you are using. Otherwise the MWE is not compilable. Commented Sep 26, 2019 at 14:05

1 Answer 1

2

Are you perhaps using the interact template from International Journal of Human–Computer Interaction? It links to this template.

The template's preamble has

\usepackage[caption=false]{subfig}

which stops the caption package from loading so that it doesn't override interact's caption redefinition. But your code has

\usepackage{subfig}

so caption has indeed overriden things.

Therefore you can follow the journal sample code's example, and add the caption=false option to your subfig package line.

2
  • When I add caption=false, the caption works fine with good syntax but it's not centered. Do you know how I can centered this ? I tried to add \centering just before \caption but it doesn't seem to work.
    – Essex
    Commented Sep 27, 2019 at 7:37
  • That's exactly how the journal's template has styled captions, i.e. the figure captions are meant to be justified, not centered; so you shouldn't change it.
    – imnothere
    Commented Sep 27, 2019 at 14:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .