1

I have a problem with the tabular environment:

\documentclass{article}

\begin{document}
\begin{tabular}{ccc}
  \begin{minipage}[t]{0.33\linewidth}
    \fbox{\parbox{4cm}{Texte 1

        Texte 2

        Texte 3}}
  \end{minipage}
  &
  \begin{minipage}[t]{0.33\linewidth}
    \fbox{\parbox{4cm}{Texte 1}}
  \end{minipage}
  &
  \begin{minipage}[t]{0.33\linewidth}
    \fbox{\parbox{4cm}{Texte 1

        Texte 2

        Texte 3

        Texte 4}}    
  \end{minipage}
\end{tabular}
\end{document}

I can't find the right options to put in minipage so that the boxes are vertically aligned on their tops.

Can anyone help me ?

Thanks.

1 Answer 1

3

You have the correct option for the minipages, they are aligned by the first line of text in them. But the first line has \parboxes, and they are centered on the line by default. Hence, with \parbox[t]{4cm}{..} you get what you're after.

But if you only have a \parbox in the minipages, then you probably don't need both, so you could remove all the minipage environments. For example:

\documentclass{article}

\begin{document}
\begin{tabular}{ccc}
    \fbox{\parbox[t]{0.3\linewidth}{Texte 1

        Texte 2

        Texte 3}}
  &
    \fbox{\parbox{0.3\linewidth}{Texte 1}}
  &
    \fbox{\parbox[t]{0.3\linewidth}{Texte 1

        Texte 2

        Texte 3

        Texte 4}}    
\end{tabular}
\end{document}
1
  • Thank you very much. This did the trick. Sep 29, 2019 at 11:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .