0

That's what I'm doing, everything works fine but the graphic of the function.

\documentclass{standalone}

\usepackage{tkz-fct}

\begin{document}

    \begin{tikzpicture}
    \tkzInit[xmax= 110,xstep=10,
    ymax=6,ystep=1]
    \tkzDrawX[label={\textit{Age}},below= -18pt]
    \tkzLabelX
    \tkzDrawY[label={\textit{litres}}]
    \tkzFct[domain = 0.1:100 ]{50/\x}
    \end{tikzpicture}
\end{document}
  • 1
    Welcome! Run this with the -shell-escape option. Or switch to pgfplots: \documentclass{standalone} \usepackage{pgfplots} \pgfplotsset{compat=1.16} \begin{document} \begin{tikzpicture} \begin{axis}[axis lines=middle,xmax=115,ymax=6,xlabel=Age,ylabel=litres] \addplot[domain = 0.1:100,smooth,samples=101]{50/x}; \end{axis} \end{tikzpicture} \end{document} – user194703 Sep 29 '19 at 5:00
  • Thx, Schrödinger's cat. I'm kind of used to \tkzFct and I never had this problem before, so I'd rather continue using it. What's the -shell-escape option? – Math_Hater Sep 29 '19 at 5:08
  • What I meant by that is that if I compile your code with pdflatex -shell-escape the function appears. If I drop -shell-escape the plot is empty. You can also use lualatex -shell-escape or xelatex -shell-escape to compile your file. – user194703 Sep 29 '19 at 5:14
  • What -shell-escape does is to allow pdflatex to execute other programs during the compilation. That's absolutely necessary for tkz-fct, because it calls on Gnuplot to do the calculations. If it worked before you must have had -shell-escape/write18 (same thing) enabled, unwittingly or not. – Torbjørn T. Sep 29 '19 at 7:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.