0

I am using the natbib style plainnat, where I have modified a few of the settings to get the bibliography style that I want. For the @article entry, somehow the journal title is not included.

The article function looks like this in my .bst file:

FUNCTION {article}
{ output.bibitem
  format.authors "author" output.check
  author format.key output
  new.block
  format.title "title" output.check
  new.block
  crossref missing$
    { journal emphasize "journal" output.check
      eid empty$
        { format.vol.num.pages output }
        { format.vol.num.eid output }
      if$
      format.date "year" output.check
    }
    { format.article.crossref output.nonnull
      eid empty$
        { format.pages output }
        { format.eid output }
      if$
    }
  if$
  format.issn output
  format.doi output
  new.block
  note output
  fin.entry
}

I have looked through the rest of the .bst file, but can't find a function for the journaltitle entry in my .bib file. .bib-file entry example:

@article{KompLindgren2003,
  title = {Mutation Rate and Evolution of Fluoroquinolone Resistance in {{{\emph{Escherichia}}}}{\emph{ coli}} Isolates from Patients with Urinary Tract Infections.},
  volume = {47},
  issn = {0066-4804},
  url = {http://www.ncbi.nlm.nih.gov/pubmed/14506034 http://www.pubmedcentral.nih.gov/articlerender.fcgi?artid=PMC201150},
  doi = {10.1128/AAC.47.10.3222},
  number = {10},
  journaltitle = {Antimicrobial agents and chemotherapy},
  date = {2003-10},
  pages = {3222--32},
  author = {Komp Lindgren, Patricia and Karlsson, Asa and Hughes, Diarmaid},
  eprinttype = {pmid},
  eprint = {14506034}
}

With the current style, the bibliography looks like this:

enter image description here

I would like to have the journal title before the Volume,Pages etc (47(10):3222 - 32), and year afterwards. Is there a simple way to do this? I have tried to add a function for journaltitle like this:

FUNCTION {jorunal.title}
{ journaltitle empty$
    { "" }
    { journaltitle }
  if$
}

But that gave me a bunch of errors.

  • just replace your journaltitle with journal in your entry ... Journal is supposed to be visible in every @article entry. But if bibtex find an unknown field as journaltitle it will ignore it. Also replace date by year and month separate fields... – koleygr Sep 30 '19 at 11:51
  • @koleygr I create the .bib file with Zotero and BetterBibtex, so these fields are named automatically. How would you suggest to change this? – Haakonkas Sep 30 '19 at 12:10
  • I suggest just to replace the journaltitle with journal by using an editor with "replace feature" like emacs or whatever and change manually the date field... I don't use this software (Zotero and BetterBibtex) but my suggestion will make your bib file usable in other documents too ... For now seems like worseBibtex for me ... (sorry ... nothing personal ... but didn't like that a software causes this problem)... May be there is an option in your software to fix this ... take a look at its manual please – koleygr Sep 30 '19 at 12:16
1

This was fixed by changing my Zotero BetterBibtex translator from Better Biblatex to Better Bibtex, as mentioned here: https://github.com/retorquere/zotero-better-bibtex/issues/73

journaltitle is specific to biblatex, while journal is specific for bibtex.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.