0

I am on a mac using Tex Live 2019 with Sublime Editor

I have recently updated all packages with tlmgr update --all (I confirm that I have the latest songs package 3.1)

When I compile the following example (from the songs website):

% Copyright (C) 2018 Kevin W. Hamlen
\documentclass[letterpaper]{article}
\usepackage[bookmarks]{hyperref}
\usepackage[chorded]{songs}
% \includeonlysongs{2}

\setlength{\oddsidemargin}{0in}
\setlength{\evensidemargin}{0in}
\setlength{\textwidth}{6.5in}
\setlength{\topmargin}{0in}
\setlength{\topskip}{0in}
\setlength{\headheight}{0in}
\setlength{\headsep}{0in}
\setlength{\textheight}{9.1in}
\settowidth{\versenumwidth}{1.\ }
\pagestyle{empty}

\newindex{titleidx}{cbtitle}
\newauthorindex{authidx}{cbauth}
\newscripindex{scripidx}{cbscrip}

\begin{document}

\showindex{Complete Index of Songs}{titleidx}

\songsection{Worship Songs}
\begin{songs}{titleidx,authidx,scripidx}
\beginsong{Doxology}[
  by={Louis Bourgeois and Thomas Ken},
  sr={Revelation 5:13},
  cr={Public domain.},
  index={Praise God, from Whom all blessings flow}]
\beginverse*
\[G]Praise God, \[D]from \[Em]Whom \[Bm]all \[Em]bless\[D]ings \[G]flow;
\[G]Praise Him, all \[D]crea\[Em]tures \[C]here \[G]be\[D]low;
\[Em]Praise \[D]Him \[G]a\[D]bove, \[G]ye \[C]heav'n\[D]ly \[Em]host;
\[G]Praise Fa\[Em]ther, \[D]Son, \[Am]and \[G/B G/C]Ho\[D]ly \[G]Ghost.
\[C]A\[G]men.
\endverse
\endsong
\end{songs}

\showindex{Index of Authors and Composers}{authidx}
\showindex{Index of Scripture}{scripidx}

\end{document}

I successfully get a pdf with the song, but without any index. Neither the Complete Index of Songs, nor any other.

Then I tried the solution in here to run

pdflatex myfilename.tex
texlua songidx.lua lbtitle.sxd lbtitle.sbx
pdflatex myfilename.tex

But still the generated pdf did not have the indices

What am I missing?

2
  • 1
    Perhaps yuop should make this example into something self contained. We do not have access to songs.sbd thus cannot test the MWE.
    – daleif
    Oct 2, 2019 at 11:44
  • @daleif MWE created and included. Thanks
    – gota
    Oct 2, 2019 at 12:41

1 Answer 1

1

I am able to get this to work on my TeXLive 2019 on linux.

First I had to copy songidx.lua and bible.can to the current dir.

Then I ran

pdflatex file.tex
texlua songidx.lua cbauth.sxd
texlua songidx.lua cbscrip.sxd
texlua songidx.lua cbtitle.sxd
pdflatex file.tex
pdflatex file.tex

and I do get several indeces.

4
  • That solved my issue! Thank you. Now I have a followup question. How can I make this process automatic with a text editor such as sublime using LatexTools?
    – gota
    Oct 2, 2019 at 14:44
  • 1
    Just for others that come by what did you do wrong? Sorry cannot help you with those tools, don't use them
    – daleif
    Oct 2, 2019 at 14:53
  • I had not copied bible.can to the current dir. And I had not ran pdflatex file.tex twice after the texlua commands. I don't know exactly what solved my issue
    – gota
    Oct 2, 2019 at 14:56
  • You should have been given an error on the missing bible.can. I made a loop that ran texlua on all the .sxd files and it croaked on the missing bible.can
    – daleif
    Oct 2, 2019 at 15:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .