29

When citing online resources my university's regulation stipulates that we have to add information on when we accessed the specific website. This can for example be of the form "Retrieved: April 7, 2012".

When using the following simple setup for biblatex, is there a field in @online or so that allows me to have this printed automatically in the bibliography?

\usepackage[style=authoryear, backend=biber]{biblatex}
5
  • 2
    You need urldate. Apr 7, 2012 at 13:22
  • I specified urldate but it is ommitted in the bibliography.
    – Ingo
    Apr 7, 2012 at 13:29
  • 1
    Please see my updated answer. Apr 7, 2012 at 13:43
  • Nevermind, works now.
    – Ingo
    Apr 7, 2012 at 13:44
  • 1
    I had the same problem as @Ingo, thus the urldate was omitted in the bibliography, it was fixed by deleting all the aux files and recompiling.
    – Zwähnia
    May 30, 2013 at 14:12

1 Answer 1

42

As I recommend in the comment you need the field urldate. Here an example:

\documentclass{article}

\usepackage[style=authoryear, backend=biber]{biblatex}
\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@Online{ctan,
  label       = {CTAN},
  title       = {CTAN},
  subtitle    = {The Comprehensive TeX Archive Network},
  date        = {2006},
  url         = {http://www.ctan.org},
  urldate     = {2012-04-07},
}
\end{filecontents}
\addbibresource{\jobname.bib}

\DefineBibliographyStrings{english}{%
urlseen = {Retrieved},
}

\begin{document}
Text \cite{ctan}

\printbibliography
\end{document}

I also changed urlseen to your required string: "Retrieved".

If you want to format urldate you can use the following options of biblatex:

urldate=comp,dateabbrev=false

The result will be: April 7

The result is: enter image description here

2
  • @Ingo In case you use JabRef to manage your literature: it automatically sets an insert date to the timestamp field for a new entry. Luckily, the target field can be changed to urldate in the program's preferences. The date format, however, does not accept the YYYY-MM-DD format. It always puts YYYY.MM.DD and I cannot tell if this works with @MarcoDaniel's solution!?
    – JJD
    Jul 15, 2012 at 22:47
  • I had the same question, and this has been very helpful. However, when I add the urldate=comp,dateabbrev=false options, the "Retrieved" phrase is gone from the citation.. Any ideas?
    – geo909
    Aug 12, 2013 at 17:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .