0

I'm using the MacTeX 2019 environment on macOS Mojave 10.14.6 and the included pdfLaTeX and biber commands to compile my documents (through TeXStudio, although running directly from command line leads to the same problems).

The problem I have is that most bibliography styles I set in the \usepackage block of biblatex are not being recognized, as in something like this shows up when I compile while the bib style is set to lni:

Package biblatex Error: Style 'lni' not found.

Now this sounds like the package for this bibliography style is simply not installed. I checked this in the TeXLive Utility, and sure enough, it appears as installed through that Screenshot from TeX Live Utility

I tried reinstalling everything already. The problem persists even on a clean install.

I also checked whether the package was actually there or not within the MacTeX package structure, and it appeared under

/usr/local/texlive/2019/texmf-dist/tex/latex/biblatex-lni

which is directly next to the actual biblatex installation under

/usr/local/texlive/2019/texmf-dist/tex/latex/biblatex

which is also where the error is being raised, that the bibliography style isn't being found.

Two more curious things about this: When I use a default bibliography style like "authortitle", everything works fine and no errors are raised during compiling.

Additionally, I used to be able to compile documents using the LNI and APA bibliography styles on this machine a few months ago, and I have not knowingly changed anything in my distribution when it suddenly stopped working a few weeks ago.

Does anyone have an idea how I can bring BibLaTeX and Biber to find these additional bibliography styles again? If anything, a pointer towards how I could manually include these styles would greatly help me as well, as I've unfortunately not really been able to find anything helpful on the internet on this topic so far (Or at least nothing that worked on my end).

Thanks in advance!

Minimum example:

\documentclass{article}
\usepackage[
backend=biber,
style=lni,natbib=true,maxbibnames=99,firstinits=true]{biblatex}
\ExecuteBibliographyOptions{sorting=nty}
\addbibresource{quellen.bib}

\begin{document}

This is a minimum (not) working example.

\end{document}
  • On my machine the style name of the .bbx and .cbx in biblatex-lni is in uppercase. I thought that there was a change to make TeX case insensitive a while ago, but try style=LNI instead of style=lni. – moewe Oct 6 at 13:31
  • @moewe Lol that's literally it. What a simple mistake. Could you submit this is an answer so I can mark it as solved? Also it's really weird that this used to work before and apparently it became case sensitive again with a newer update? Wtf. – cmarc Oct 6 at 13:38
1

Interestingly, the file names of the biblatex-lni package use uppercase base names and are called LNI.bbx and LNI.cbx.

More interestingly, even though TeX live's file searching has been case-insensitive since 2018 the files are not found on your case-sensitive system if you use the lowercase style=lni,.

Solution: Use the uppercase names

style=LNI,

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.