0

I produce my graph with gnuplot and then pdflatex. I always used this header that has alwasy worked

set terminal epslatex standalone color size 4.0in,3.0in background rgb "white"
set output 'plot.tex'

Unfortunately after having run

gnuplot plot.gnu && pdflatex plot.tex

I got the following error

pdfTeX warning: pdflatex (file ./pm-inc-eps-converted-to.pdf): PDF inclusion: found PDF version <1.7>, but at most version <1.5> allowed

Any idea how to solve it?

I also run the gnuplot test and the results differs fromt the one posted in this thread https://stackoverflow.com/questions/19412382/gnuplot-line-types. It seems I don't have any kind of linetype

enter image description here

  • 1
    Did you Google the message? Sends you to tex.stackexchange.com/q/52317/3929, shouldn't be hard to adapt to your case – daleif Oct 7 at 17:52
  • I saw that thread. The problem is it gives only a manual solution by adding to the tex file "\pdfminorversion=6". This is very uncomfortable because everytime you recreate the .tex file you need to add that line manually. – FlyBob Oct 7 at 17:55
  • 1
    Then have your gnuplot generate pdf 1.5 and not 1.7 – daleif Oct 7 at 17:57
  • Or rephrase your question to reflect this, it us not at all clear that this is what you're after – daleif Oct 7 at 17:58
  • The final .pdf created is in verison 1.5, the intermediate one in 1.7. Anyway the results is not what I want because of the warning message and it seems some features are turned off. – FlyBob Oct 7 at 17:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.