0

When using ctex combined with xeLatex, I found there are some missing characters in ctex, so I wonder how to solve this issue ?

For example, character .

\documentclass[a4paper, 11pt]{article}
\usepackage[UTF8]{ctex}
\begin{document}
你就是祂
\end{document}

enter image description here

  • Welcome to TeX.SX! I tried with TeX Live from 2016 to 2019 and always got four characters. Can you please show the log file? – egreg Oct 9 at 8:35
  • @egreg Sure. I tried with VScode latexshop and overleaf, but neither of them could work. Here is the Overleaf link, you can find the log file here. overleaf.com/read/bwjzvcmvnrfm – Wayne Mai Oct 9 at 8:56
  • 2
    You get There is no 祂 in font [FandolSong-Regular.otf]/OT. Use a different font; the manuals of ctex are in Chinese, so I'm not able to suggest how to do it. – egreg Oct 9 at 9:00
  • @egreg Thank you so much ! After I referred to ctex manual, now I have worked it out. – Wayne Mai Oct 9 at 9:28
2

According to ctex Chinese manual(page 9), changing the font can solve the character missing problem:

\documentclass[UTF8,nofonts]{ctexart}
\setCJKmainfont[BoldFont=STHeiti,ItalicFont=STKaiti]{STSong}
\setCJKsansfont[BoldFont=STHeiti]{STXihei}
\setCJKmonofont{STFangsong}

\begin{document}
你就是祂
\end{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.