3

I have the same problem as stated in this post. After updating MikTeX I am unable to compile LaTex files that contain \includegraphics{}. The temporary fix from Joseph Wright solved the problem. My MiKTeX-distribution is up-tp-date.

A comment from COOLSerdash suggested to update the formats from MiKTeX

Settings -> Formats -> Build format

both in user and admin mode. But I get an error:

enter image description here

fileName="C:\Program Files\MiKTeX 2.9\miktex/bin/x64\initexmf.exe", exitCode="1", savedOutput="C:\ProgramData\MiKTeX\2.9\miktex\log\initexmf_2019-10-09-073658.out"

What else can I do to solve the problem?


Solution

My problem was, that I selected all formats and rebuild all of them. After I just selected pdflatex and rebuild the format this fixed the problem. I run the update in User and Admin mode.

Now I get the correct entry: LaTeX2e <2019-10-01>.

  • Run the update in user and admin mode, if the problem persist, open an issue at the miktex issue tracker and don't forget to mention what the output file in the error message says. – Ulrike Fischer Oct 9 at 12:28
  • I had the same problem rebuilding the formats. It was solved by turning off my anti-virus software. I suppose my anti-virus software is too aggressive on MiKTeX (I turn it off whenever I update packages). – Ruixi Zhang Oct 10 at 2:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.