This is perhaps a very stupid question -- I'm trying to get the luximono font activated for listings in a LaTeX document. I'm not very LaTeX savvy concerning the whole TeX installation architecture. I am on OS X 10.6, and I am using TeXShop. I understand that luximono is not part of the normal tex live installation. So what I did is follow the instruction of this question. I have now


in my document, but the font of the listing looks all bad, some serif font. I get an error message in the log:

LaTeX Font Warning: Font shape `OT1/ul9/m/n' undefined
(Font)              using `OT1/cmr/m/n' instead on input line 175.

I have a hunch that when I ran getnonfreefonts -a, there is no environment variables $TEXMFHOME or $TEXMFLOCAL set, so perhaps it installed in the wrong place?

I have folder /usr/local/texlive/ on my computer, I don't know if this is the right place, or if the standard OS X ghostscript is somewhere else?


Maybe this helps: I seem to have two folders, /usr/local/texlive/2010/texmf/fonts and /usr/local/texlive/texmf-local/fonts. The installation was done into the latter.


It does also require use of package


– without it you get wired results.

...found in a comment to this post. Now it works!

By the way, it seems indeed to pick up the TEXMFHOME installation in ~/Library/texmf while /usr/local/texlive/texmf-local is wrong (updmap looks in /usr/local/texlive/2010/texmf instead).

  • 1
    The reason it put the fonts in ~/Library/texmf is because you used getnonfreefonts instead of sudo getnonfreefonts-sys. The latter installs in /usr/local/texlive/texmf-local. – Alan Munn Apr 8 '12 at 11:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.