1

It took me a long time to get arara to work from within TeXworks on OS X 10.14 or 10.15. I would get two errors:

/usr/local/texlive/2019/texmf-dist/scripts/arara/arara.sh: line 8: kpsewhich: command not found
Unable to access jarfile 

I eventually found the problems: the system path was not inherited by the sh script and the scriptname variable contains the file extension (so jar was getting set to arara.sh.jar instead of arara.jar).

I fixed it by adding:

PATH=/Library/TeX/texbin:$PATH

To the first line of the arara.sh file and then I changed

jar="$scriptname.jar"

to

jar="arara.jar"

Once I made those two changes, it worked like a charm.

Is this a known issue?

Edit: One thing to add, if I call arara directly from terminal, it works correctly without modifications to the sh file. I only have issues when calling it from TeXworks.

5
  • Welcome! What is sh on your system? For example, what does sh --version give?
    – cfr
    Oct 13, 2019 at 3:44
  • @cfr GNU bash, version 3.2.57(1)-release (x86_64-apple-darwin18) Copyright (C) 2007 Free Software Foundation, Inc.
    – Daniel W
    Oct 13, 2019 at 13:13
  • Maybe ask the author of arara. I don't know how Macs are set up now. There's no reason you should have to make those changes. Especially, the second one sounds very odd indeed.
    – cfr
    Oct 13, 2019 at 18:51
  • I was able to change how I call arara from TeXworks from directly calling arara.sh with the full path to calling "arara" and that removed the need for the edit to the jar definition. The first edit still seems to be required.
    – Daniel W
    Oct 14, 2019 at 11:46
  • What do echo $PATH and which kpsewhich return on your system? Nov 27, 2019 at 14:33

0

You must log in to answer this question.

Browse other questions tagged .