3

I am using XeTeX, Version 3.14159265-2.6-0.999991 (MiKTeX 2.9.7200 64-bit) in a docker container with Windows Server 2016.

When I run the command xelatex --interaction=nonstopmode test.tex I obtain this error: Error -1073741571 (driver return code) generating output; file test.pdf may not be valid. and no pdf is generated.

However when I run xelatex --interaction=nonstopmode --no-pdf test.tex and then xdvipdfmx test.xdv (what is perfectly equivalent according to this post: Generating PDF from xelatex), it works.

For certain reasons, I would like to make it work in one single command. I don't have any other relevant information in any log files (in the log files I know).

Thanks for your help.

  • 2
    Welcome to TeX.SX! Could you try bisecting your document to a minimal example that demonstrates the issue, please? – Phelype Oleinik Oct 15 '19 at 10:24
  • Here is the latex code: \documentclass{article} \begin{document} TEST \end{document} – Maxime Mathy Oct 15 '19 at 10:35
  • Oh, I thought it would be something more complicated than that. Sorry, I can't reproduce the problem with TeXLive. – Phelype Oleinik Oct 15 '19 at 10:42
  • You could enable tracing to find out more. My guess would be that MiKTeX has problems to write or use the intermediate temporary file. – Ulrike Fischer Oct 15 '19 at 11:28
  • try xelatex -output-driver='xdvipdfmx -E' (so not -q) then the internal call to xdvipdfmx will log errors to the terminal – David Carlisle Oct 15 '19 at 12:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.