0

I have a Dell XPS 15 with MikTex 2.9 installed. For some reason, and without reason, when I open a tex file within TeXworks, the fonts looks like chinese (see graphic). Oddly, it compiles fine. If I create a new file and open the original file in notepad, and paste the original text from notepad to a new file within TeXworks and then try to Typeset the file I get a "Undefined control sequence." The crazy looking file is attached. I am not having this problem on my desktop nor do I have this problem if I open this same file in TeXStudio.

Thoughts on what could be causing this?

Thanks!

enter image description here

  • Note: I never had a problem prior to today and I have been using MikTeX on my laptop for about 3 weeks now without an issue. – calmymail Oct 18 at 0:16
  • 1
    welcome to tex.sx. – barbara beeton Oct 18 at 0:21
  • 1
    It looks like you opened the file with a different encoding e.g., your file is utf8 and you opened with utf16, or something like that. See if you can reopen the file with the correct encoding (most likely utf8). – Phelype Oleinik Oct 18 at 1:57
1

Like Phelype Oleinik already said, it seams to be the wrong encoding. You can change the Enconding like that:

Edit->Preferences->Editor

There is an option called 'Encoding' choose UTF-8.

  • Thanks for the suggestion. On my desktop it is UTF-8. I changed the default on my desktop to UTF-8 (it was something different.) However, I get strange characters, although a different set of characters. Any other suggestions? – calmymail Oct 19 at 23:22
  • Did you try to open the file with another editor? - Whats the result? – Ahrtaler Oct 21 at 9:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.