I would like to label the last line of this computation (and several longer ones), so I may use them as equations, like so:


\Gamma^{l}_{js}P^{j}Q^{s} &= \frac{1}{2}(\Gamma^{l}_{js}(P+Q)^{j}(P+Q)^{s} - \Gamma^{l}_{js}P^{j}P^{s} -\Gamma^{l}_{js}Q^{j}Q^{s})= & \\
&=\frac{1}{2}(f(x,P+Q)(P+Q)^{l} - f(x,Q)Q^{l} - f(x,P)P^{l})\label{eq31}

I've tried to do this with a combination of the equation and split environments, but without success. I would like:

  1. The first line in the chain to be left-aligned (this is optional)
  2. The following lines to have aligned "=" with the first "=" in the first line
  3. The last line to have a label at the end of it, so it can be referenced

So far I've only been able to achieve 1. and 2., but not 3. How can I do this?

  • Use flalign (nostar) and add \notag to each line that you want to have unnumbered. Another possibility, as you seem to have a single alignment column: with the fleqn environment from nccmath and the aligned environment
    – Bernard
    Oct 20, 2019 at 11:06
  • that's the thing. I don't need an ordinary number. I need something I can use /ref with. Oct 20, 2019 at 11:23
  • With \notag except for a single line, this single line can be referenced. But I think the other solution is simpler.
    – Bernard
    Oct 20, 2019 at 11:45

1 Answer 1


A solution with fleqn from nccmath and aligned[b] nested in equation. I also repplcad the fractionary coefficient witha medium-sized fraction (also from nccmath which looks better in my opinion.

The fleqn environment makes locally equations start at the left margin; an optional arguments gives the possibility to set at what distance from the (text) left margin equations start – default is 0pt.

\usepackage{mathtools, nccmath}


\noindent  We denote $ \Gamma^{l}_{js}$ as a shorthand for $ \Gamma^{l}_{js}(g, m)$
  \Gamma^{l}_{js}P^{j}Q^{s} &= \mfrac{1}{2}\bigl(\Gamma^{l}_{js}(P+Q)^{j}(P+Q)^{s} - \Gamma^{l}_{js}P^{j}P^{s} -\Gamma^{l}_{js}Q^{j}Q^{s}\bigr)=  \\
&=\mfrac{1}{2}\bigl(f(x,P+Q)(P+Q)^{l} - f(x,Q)Q^{l} - f(x,P)P^{l}\bigr)\label{eq31}


enter image description here

  • I can't install nccmath because the MiKTeX package repository is currently offline. I will accept the answer once I check the code tomorrow. Oct 20, 2019 at 12:04
  • You can change repository with MiKTeX console (Settings button).
    – Bernard
    Oct 20, 2019 at 12:06
  • It's a more general problem: miktex.org/alert/update-problem-7231 but the github ticket says it will be fixed tommorow Oct 20, 2019 at 12:16
  • 1
    You can download it directly from CTAN and use a local package repository. You just have to download ncctools.tar.lzma and 5 complementary files (for a valid repository: pr.ini, files.csv.lzma, miktex-zzdbi-2.9.tar.lzma (i=1,2,3).
    – Bernard
    Oct 20, 2019 at 12:27
  • 1
    I think this is due to the fractions on both lines. This being said, the interline spacind in amsmath environments is controlled by the value of \jot (defaults to 3pt), which can be changed after begin{document}<. You also have the \spreadlines environment from mathtools for local modifications.
    – Bernard
    Oct 21, 2019 at 9:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .