5

just a quick question about Xelatex and Minion Pro. By default, uppercase letters as well as lowercase greek letters in math mode are italics. Can I get them upright by hand?

So far, I am using:

\usepackage[MnSymbol]{mathspec}
\usepackage{xltxtra}
\defaultfontfeatures{Scale=MatchLowercase}
\setmainfont[Mapping=tex-text]{Minion Pro}
\setsansfont[Mapping=tex-text]{Myriad Pro}
\setmathfont(Digits,Latin,Greek){Minion Pro}

maybe I should work with something like:

\setmathsfont[Set=Greek,Uppercase=Italic,Lowercase=Italic]{Minion Pro}

Thanks.

1 Answer 1

3

Just break your \setmainfont into two lines, and you should have separate control over Greek and Latin. E.g., to get Latin in italics and upright Greek:

 \setmathfont(Digits,Latin)[Uppercase=Italic,Lowercase=Italic]{Minion Pro}
 \setmathfont(Greek)[Uppercase=Regular,Lowercase=Regular]{Minion Pro}

(Reverse the options if you want upright Latin and italic Greek.)

Or maybe I just didn't understand what you were trying to do.

2
  • perfect. I think I want this : \setmathfont(Digits,Latin,Greek)[Uppercase=Regular,Lowercase=Italic]{Minion Pro}. There is still something unclear. If I define \DeclareMathOperator{\dive}{div} and use it whithin a math mode, the font of "div" is not Minion. Why?
    – pluton
    Nov 9, 2010 at 19:03
  • 2
    \DeclareMathOperator uses the mathrm alphabet. So you'd need \setmathrm{Minion Pro} -- see page 5 of the mathspec documentation.
    – frabjous
    Nov 9, 2010 at 20:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.