2

I have a problem which I can't solve by myself or haven't found anywhere:

I'm citing the same author (and year) with two different sources. In the bibliography the second entry only has a big dash instead of the author again, which I would prefer. Any suggestions to get the same author being displayed again there?

Code example:

\documentclass{article}
\usepackage[utf8]{inputenc}
\usepackage{blindtext}
\usepackage[style=authoryear,maxnames=2,sorting=nyt,isbn=true,url=true,block=space,natbib=true]{biblatex}
\addbibresource{bib.bib}
\title{Hi}
\author{MM}
\date{November 2019}

\begin{document}

\maketitle

\section{Introduction}

\blindtext\citep{bundesregierung_klimaschutzgesetz_nodate}\citep{bundesregierung_klimaschutzprogramm2030_2019}

\printbibliography

\end{document}

In the bib.bib file there are these two entries:

@misc{bundesregierung_klimaschutzprogramm2030_2019,
title = {Klimaschutzprogramm 2030},
url = {https://www.bundesregierung.de/breg-de/themen/klimaschutz/klimaschutzprogramm-2030-1673578},
language = {de},
urldate = {2019-11-04},
author = {{Bundesregierung}},
year = {2019},
}

@misc{bundesregierung_klimaschutzgesetz_nodate,
title = {Klimaschutzgesetz},
url = {https://www.bundesregierung.de/breg-de/themen/klimaschutz/kimaschutzgesetz-beschlossen-1679886},
urldate = {2019-11-05},
author = {{Bundesregierung}},
year = {2019},
}

The output looks something like this: My output

  • 1
    Welcome to TeX.SX! Thank you for a very clear first question with a good code example to go with it. For future questions you can make the example even more minimal by dropping the blindtext and the title as well as section headings if they are not needed to show the problem. – moewe Nov 5 at 16:52
  • Thanks for the feedback. I will minimize the example if I have another question. I'm sorry for the dublicate but I was going crazy with it and since the answer is quite simple, I feel a bit stupid! But I'm very greatful for your help! – Frederick Nov 6 at 8:16
  • Please don't worry about the duplicate. It is much easier finding the duplicate question once you know the answer and can search for it. – moewe Nov 6 at 20:27
2

Add the option dashed=false when loading the package biblatex:

\usepackage[...,dashed=false]{biblatex}

Not the answer you're looking for? Browse other questions tagged or ask your own question.