1

I am using texlive-full installation and TexMaker IDE.

I have done a manual installation (mkdir and copy paste .sty file) under

/usr/share/texlive/texmf-dist/tex/latex/nicematrix/nicematrix.sty

When I include \usepackage{nicematrix} and try to compile with PDFLatex my IDE goes into an infinite run. I have to break it with a stop button. At this point I get the following errors:

Here is the error log file: link

Please help me fix this. Thank you.

Things tried:

  1. Checked for all other dependent packages -- they exist
  2. Did a user wide installation -- same error
  3. Restarting everything after installation -- same error

Below is the minimum working example:

\documentclass[letterpaper]{article}
\usepackage{proceed2e}
\usepackage[margin=1in]{geometry}

% Set the typeface to Times Roman
\usepackage{times}

% The following packages can be found on http:\\www.ctan.org
\usepackage[]{graphics}
\usepackage{epsfig} % for postscript graphics files
\graphicspath{{figs/}}
\usepackage[font=small,skip=6pt]{caption}
% Algorithm Environment
\usepackage{algpseudocode,algorithm,algorithmicx}
\renewcommand{\algorithmicrequire}{\textbf{Input:}}
\renewcommand{\algorithmicensure}{\textbf{Output:}}
% Custom colors
\usepackage{color}
\usepackage[dvipsnames]{xcolor}
\usepackage[hidelinks]{hyperref}

\usepackage{amsmath}
\usepackage{amssymb}  % assumes amsmath package installed
\usepackage{pifont}
\usepackage{marvosym}
\usepackage{mathtools}
\usepackage{mathrsfs}  % 

\usepackage{enumerate}
\usepackage{graphicx}
\usepackage{subfig}

\usepackage{tikz}
\usetikzlibrary{bayesnet}
\usetikzlibrary{decorations.pathreplacing,calc} % braces {}
\usetikzlibrary{shapes,arrows,positioning}
\usepackage{pgfplots}
\pgfplotsset{compat=1.8}


\tikzset{
 block/.style={
  draw, 
  rectangle, 
  minimum height=2em, 
  minimum width=5em,
 },
 sum/.style={
  draw, 
  circle, 
  minimum size=2em
 },
 input/.style={coordinate}, 
 output/.style={coordinate},
 mytext/.style={
  draw,
  text depth=4pt,
  text height=10pt
 }
}
\def\-{\raisebox{.75pt}{-}}

\usepackage{multirow}
% For developing the paper
%-------------------------
\usepackage[colorinlistoftodos,prependcaption,textwidth=20mm,textsize=tiny,color=yellow]{todonotes}
\usepackage{xargs}
\newcommandx{\unsure}[2][1=]{\todo[linecolor=red,backgroundcolor=red!25,bordercolor=red,#1]{#2}}
\newcommandx{\change}[2][1=]{\todo[linecolor=blue,backgroundcolor=blue!25,bordercolor=blue,#1]{#2}}
\newcommandx{\info}[2][1=]{\todo[linecolor=OliveGreen,backgroundcolor=OliveGreen!25,bordercolor=OliveGreen,#1]{#2}}
\newcommandx{\improvement}[2][1=]{\todo[linecolor=Plum,backgroundcolor=Plum!25,bordercolor=Plum,#1]{#2}}
\newcommandx{\thiswillnotshow}[2][1=]{\todo[disable,#1]{#2}}

\usepackage[normalem]{ulem}
\usepackage{balance}

\usepackage{nicematrix} % <-------------------HERE

%%%   WRITING BEGINS %%%%
%-------------------------
\title{\LARGE \bf
Large Network Modelling Using Horses and Apples
}

\renewcommand\footnotemark{}
\renewcommand\footnoterule{}

\author{John Doe$^{\dagger}$, John Ek $^{*}$ and John Jen$^{\dagger \theta}$ }
\thanks{$^{\theta}$Author order to be decided.}


\begin{document}

\maketitle

\begin{abstract}

Real-world large can be modelled using 
Graphs. Such a model is parametrised by a basis matrix, whose 
size is orders of 
\end{abstract}

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
\section{Introduction}
\label{sec:Introduction}

Real-world very large networks can be modelled using  
Graphs. Such a model is parametrised by a basis matrix, whose 
size is orders of magnitude smaller, blah blah

\bibliographystyle{IEEEtran}
\balance
\bibliography{references}

\end{document}

EDIT:: Fixed! So the point raised by @daleif is correct. My version of TeXLive - which is the actual distribution version for ubuntu 16.04, is 2015. This is too old. I tried many things as seen in the comments and none of them work - ended up crashing my Ubuntu also, as I removed some dependencies.

Now I finally did the following: 1. Updated Ubuntu Xenial generic, headers, images etc. 2. added ppa with :ppa-link 3. Update, Upgrade, Autoremove 4. I have texlive version 2018. No side install. No equivs. 5. This has nicematrix package by default!

Update-1: Any idea why just NiceArray and all its subtypes bNiceArray and so on are "package not found" but NiceMatrix works just fine? Below is the MWE that does not compile/work (All examples are from Stack Exchange/Documentation):

\documentclass[12pt,oneside]{article}
\usepackage{nicematrix}

\begin{document}
    \[
P = \begin{bNiceArray}{C CCCC}
a       & 0 & 0 & \dots & 0     \\
0       & \Block{4-4}<\huge>{Q} \\
0       &   &   &       &       \\
\vdots  &   &   &       &       \\
0       &   &   &       &   
    \end{bNiceArray}
\end{document}

Output:

enter image description here

The following example compiles but executes with some bugs:

\documentclass[12pt,oneside]{article}
\usepackage{nicematrix}

\begin{document}
$\begin{pNiceMatrix}[nullify-dots]
a& b& 0&& \Cdots & 0\\b& a& b& \Ddots && \Vdots \\0& b& a& \Ddots &&\\& \Ddots & \Ddots & \Ddots && 0\\\Vdots &&&&& b\\0& \Cdots && 0& b& a
\end{pNiceMatrix}$

\bigskip
\bigskip
\bigskip
\bigskip

\[
\begin{pmatrix}
     1 & \cdots & \cdots & 1      \\
     0 & \ddots &        & \vdots \\
\vdots & \ddots & \ddots & \vdots \\
     0 & \cdots & 0      & 1
\end{pmatrix}
\]

\end{document}

OUTPUT: First matrix has random text and too many dots

  • As stated in the question, the problem has been solved. The comment conversation has been moved to chat, in case there is a reason to continue talking (though it stopped 1 month ago). – Stefan Kottwitz Dec 12 '19 at 13:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.