I am using texlive-full installation and TexMaker IDE.

I have done a manual installation (mkdir and copy paste .sty file) under


When I include \usepackage{nicematrix} and try to compile with PDFLatex my IDE goes into an infinite run. I have to break it with a stop button. At this point I get the following errors:

Here is the error log file: link

Please help me fix this. Thank you.

Things tried:

  1. Checked for all other dependent packages -- they exist
  2. Did a user wide installation -- same error
  3. Restarting everything after installation -- same error

Below is the minimum working example:


% Set the typeface to Times Roman

% The following packages can be found on http:\\www.ctan.org
\usepackage{epsfig} % for postscript graphics files
% Algorithm Environment
% Custom colors

\usepackage{amssymb}  % assumes amsmath package installed
\usepackage{mathrsfs}  % 


\usetikzlibrary{decorations.pathreplacing,calc} % braces {}

  minimum height=2em, 
  minimum width=5em,
  minimum size=2em
  text depth=4pt,
  text height=10pt

% For developing the paper


\usepackage{nicematrix} % <-------------------HERE

\title{\LARGE \bf
Large Network Modelling Using Horses and Apples


\author{John Doe$^{\dagger}$, John Ek $^{*}$ and John Jen$^{\dagger \theta}$ }
\thanks{$^{\theta}$Author order to be decided.}




Real-world large can be modelled using 
Graphs. Such a model is parametrised by a basis matrix, whose 
size is orders of 


Real-world very large networks can be modelled using  
Graphs. Such a model is parametrised by a basis matrix, whose 
size is orders of magnitude smaller, blah blah



EDIT:: Fixed! So the point raised by @daleif is correct. My version of TeXLive - which is the actual distribution version for ubuntu 16.04, is 2015. This is too old. I tried many things as seen in the comments and none of them work - ended up crashing my Ubuntu also, as I removed some dependencies.

Now I finally did the following: 1. Updated Ubuntu Xenial generic, headers, images etc. 2. added ppa with :ppa-link 3. Update, Upgrade, Autoremove 4. I have texlive version 2018. No side install. No equivs. 5. This has nicematrix package by default!

Update-1: Any idea why just NiceArray and all its subtypes bNiceArray and so on are "package not found" but NiceMatrix works just fine? Below is the MWE that does not compile/work (All examples are from Stack Exchange/Documentation):


P = \begin{bNiceArray}{C CCCC}
a       & 0 & 0 & \dots & 0     \\
0       & \Block{4-4}<\huge>{Q} \\
0       &   &   &       &       \\
\vdots  &   &   &       &       \\
0       &   &   &       &   


enter image description here

The following example compiles but executes with some bugs:


a& b& 0&& \Cdots & 0\\b& a& b& \Ddots && \Vdots \\0& b& a& \Ddots &&\\& \Ddots & \Ddots & \Ddots && 0\\\Vdots &&&&& b\\0& \Cdots && 0& b& a


     1 & \cdots & \cdots & 1      \\
     0 & \ddots &        & \vdots \\
\vdots & \ddots & \ddots & \vdots \\
     0 & \cdots & 0      & 1


OUTPUT: First matrix has random text and too many dots

  • As stated in the question, the problem has been solved. The comment conversation has been moved to chat, in case there is a reason to continue talking (though it stopped 1 month ago). – Stefan Kottwitz Dec 12 '19 at 13:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.