1

Reading the poetry manual I cannot see any mention of it being incompatible with verse. On the contrary it states in the Introduction on p.2 that it is "modestly compatible". But when I try to compile a document which uses both, I get the following error:

Command \c@poemline already defined. \newcounter{poemline}

Does that mean that poetry cannot be used with verse?

5
  • I think by compatible it means here that similar document markup can be used with either package, not that you should load both Nov 9 '19 at 13:44
  • I tried to reproduce your issue but could not even get the poetry package to work. When I enter this Minimum Non-Working Example (C)(TM) it does not even compile: \documentclass[10pt,letterpaper]{letter} \usepackage{poetry} \begin{document} \begin{poem} Here I begin it \\ Tere I end it \\- \end{poem} \end{document} > Environment theindex undefined. \renewenvironment{theindex} > Undefined control sequence. H > Undefined control sequence. T You might want to stick with verse which is known to work and is used extensively, unless more knowledgeable members know the trick to make poetry work
    – user201042
    Nov 9 '19 at 13:46
  • Undefined control sequence. H is not the format of a tex error message, it would show which command is undefined. The first error from theindex is because you use letter class, the poetry package assumes a class that defines an index, eg article (although if I change your example to article it runs without error but with the (major) warning \end occurred inside a group at level 2) Nov 9 '19 at 14:20
  • I compile the example with letter or article or book class, and the error I got is "Environment poem undefined." If the error is iqnored by pressing return in Texwork, it does compile and produce a pdf file.
    – anotatta
    Feb 7 '20 at 15:11
  • Update: In TeXLive the MWE compile. But in MikTex the poetry has to be loaded specifying the path, e.g. \usepackage{C:/miktex/tex/latex/poetry/poetry}. I notice that recent MikTex distribution has an arabi package containing poetry.sty. In TeXLive the file is called arabipoetry.sty.
    – anotatta
    Feb 8 '20 at 16:18
3

I am the author of poetry.

As David Carlisle observes, "compatible with" means that you can (mostly) use your poetry written with the verse package in mind with poetry instead; it doesn't mean you should load both of them. In fact, you shouldn't load both of them; poetry is meant to replace verse, not supplement it.

David Carlisle was good enough to bring this thread to my attention, which means that the package now does work with the letter class, and any class that doesn't define an index. poetry also doesn't throw warnings anymore, again thanks to David Carlisle. v2.1 was just uploaded moments ago and should be available on CTAN shortly.

I am very surprised to see letter used for a MWE; I normally see article, and the package would have worked perfectly well with that class.

2
  • I used verse with great success up till now but I was given a requirement to include a list of poems and tried to use poem. I am getting the same error as the OP even though I am not loading verse at all. My document class is memoir, not letter. I am on texlive 2018. Any ideas? And frankly, assuming that letters can contain no poetry is strange.
    – SuperAl
    Dec 14 '19 at 14:49
  • When you have a chance, please take a look at the new question I have ascked: tex.stackexchange.com/q/520435/201502
    – SuperAl
    Dec 14 '19 at 15:03

Not the answer you're looking for? Browse other questions tagged or ask your own question.