0

I have a new Ubuntu 18 machine, with a fresh install of texlive 2017 from the Ubuntu package. The following code used to work on earlier texlive versions, but now does not even compile (with pdflatex). It breaks with "! Missing number, treated as zero" on the \animategraphics command. Any suggestions?

\documentclass[12pt,a4paper]{article}
\usepackage{graphicx}
\usepackage[autoplay,loop,width=textwidth]{animate}
\begin{document}
\animategraphics{20}{img/64_QAM_}{00}{99}
\end{document}
  • texlive 2017 isn't really fresh, can't you install texlive 2019? – Ulrike Fischer Nov 13 '19 at 15:30
  • I'm reluctant because last time I did that it broke the whole tex system because of having to texlives on the same machine. – KeithB Nov 13 '19 at 15:32
  • PS: also, because I have to maintain many machines, it's important that I stay with the standard Ubuntu package, even it it's old. The maintenance overhead of manual texlive installs is too high, – KeithB Nov 13 '19 at 15:40
1

width=textwidth is wrong, it should be width=\textwidth.

\usepackage[autoplay,loop,width=\textwidth]{animate}

  • Of course - thank you! Weird, because width=textwidth actually worked in Ubuntu 16. – KeithB Nov 13 '19 at 15:51
  • I successfully tested the example with @Ulrike 's correction on TeXLive-17. – AlexG Nov 13 '19 at 16:16
  • @KeithB Which TL version is shipping with Ubuntu-16? I would like run a test. – AlexG Nov 13 '19 at 16:21
  • Looks like it might be TL2015, but it could actually have been U14 since it last worked. Anyway, I now have it working after the correction. I guess the earlier animate version probably just ignored the incorrect option. – KeithB Nov 13 '19 at 16:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.