8

I'm running the following code using MiKTeX 2.9

\documentclass{article}  
\usepackage[inline]{asymptote}

\begin{document}
    \begin{asy}
        settings.outformat = "pdf";
        settings.prc = false;
        import three;
        size(3cm,0);
        draw(O -- 2X, blue);
        draw(O -- 2Y, green);
        draw(O -- 2Z, red);
    \end{asy}
\end{document}

by pdfLaTeX + Asymptote + pdfLaTeX. But when I zoom in the resulting pdf, it is obviously not a vector piece, as depicted below.

enter image description here

What's wrong here?!

1 Answer 1

11

If you want vector graphics, you need settings.render=0 AFAIK. See also this nice answer for what you may need to do if you want to have real 3d features. That is, if you want to have shaded surfaces and vector graphics, you may have to work harder. In the example at hand, there is no problem.

\documentclass{article}  
\usepackage[inline]{asymptote}

\begin{document}
    \begin{asy}
        settings.outformat = "pdf";
        settings.prc = false;
        settings.render = 0;
        import three;
        size(3cm,0);
        draw(O -- 2X, blue);
        draw(O -- 2Y, green);
        draw(O -- 2Z, red);
    \end{asy}
\end{document}

This is the output with maximal zoom under preview on a Mac.

enter image description here

You must log in to answer this question.