I'm using pdflatex via TeXlive, updated today, on Windows 7 with Texworks as editor, for reference.

When compiling


I get:

This is pdfTeX, Version 3.14159265-2.6-1.40.20 (TeX Live 2019/W32TeX) (preloaded format=pdflatex)
 restricted \write18 enabled.
entering extended mode
LaTeX2e <2019-10-01> patch level 2
Document Class: article 2019/10/25 v1.4k Standard LaTeX document class
! Extra \fi.
l.232 \fi


Is this a bug in the oberdiek package, is my install corrupted or I'm missing something?

  • 1
    your system is not completly up-to-date. With latex patch level 3 it compiles fine. Commented Nov 14, 2019 at 18:51
  • @UlrikeFischer Is patch level 3 available in TeXlive? I ran tlmgr update --self and it still says patch level 2. Commented Nov 14, 2019 at 19:14
  • not --self, you need to update latex. So run tlmgr update --all (or check first with tlmgr update --list). Commented Nov 14, 2019 at 19:16
  • 1
    I meant you need to update packages (probably oberdiek and iftex) - I can't see what it outdated on your side, but as latex is too old, there is probably more). Commented Nov 14, 2019 at 20:04

1 Answer 1


Some packages were corrupted (I'm not sure how).

The solution was a forced reinstall of the oberdiek bundle via tlmgr install oberdiek --reinstall.

As recommended by @UlrikeFischer, an full update via tlmgr update --all solved similar issues in other packages.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .