2

Apologies if this is not the correct place to ask this, since it is not exactly TeX specific...

I've been using Kile for a few years on my Windows 10 machine with no problem. After a Windows update, Kile suddenly no longer does anything. Upon opening Kile, I see [LivePreview-PDFLaTeX] failed to start in the messages window. Running a System Check, everything fails. For example, the test results show:

LaTeX (Critical failure, Kile will not function properly)

  • Binary: Could not find the binary for this essential tool.

It worked fine last week until I installed a Windows update and restarted my computer. Otherwise nothing changed. I already uninstalled and reinstalled Kile, but that did not help.

What could have gone wrong, and what should I do to fix it?


Edit: I still do not know what the problem is, but I tried uninstalling and reinstalling Kile one more time. I started up Kile, but it still was not working. Then I ran the command latex in the command line and restarted Kile..... and it is working!?!??! Kile now finds the binaries with no problem.

This was nothing different from what I did yesterday, but today this fixed the problem.

Who knows!

  • Does compiling LaTeX documents from the command line work? Perhaps it's just a path issue. – siracusa Nov 18 '19 at 15:49
  • I can run latex and pdftex just fine from the command prompt. I've also just installed texmaker, and I am able to compile just fine using texmaker. – luftbahnfahrer Nov 18 '19 at 15:53
  • have you updated any dependencies, e.g. cygwin? – naphaneal Nov 18 '19 at 15:56
  • Have you checked the Kile settings for missing/wrong paths? – siracusa Nov 18 '19 at 15:59
  • @napheneal I just updated cygwin and restarted, but nothing has changed. Thanks for the suggestion though. – luftbahnfahrer Nov 18 '19 at 16:10

Browse other questions tagged or ask your own question.