I use the Cochineal font for both text and math using the packages cochineal and newtxmath with the option cochineal. I use MiKTeX 2.9 on Windows 10. Everything worked perfectly fine until maybe a week ago, when I updated packages, many named miktex-.... Since these updates, when I compile any document that uses the package newtxmath with the option cochineal, I keep getting errors like

Font \csname\endcsname=cochMI at 10.95pt not loadable: Metric (TFM) file not found.

The .pdf file is still produced in the end, but all math characters based on letters or numbers are missing.

I was totally lost at first, so I just tried to uninstall both Cochineal and newtx and to reinstall them using the MiKTeX console. Actually I even tried to uninstall and reinstall the whole MiKTeX distribution from my computer.

After lots of research, I tried to verify if Cochineal and newtx were correctly installed (although I'm still not certain that I understand correctly the installation of fonts, it seems kinda complicated). I thought maybe the .tfm files from Cochineal or newtx had been lost or something, but I was able to find them in the TEXMF root directories; all of the .tfm files from Cochineal are under fonts\tfm\public\cochineal and all of those from newtx are under fonts\tfm\public\newtx. I also verified that the .map files were saved in the right folders; I have Cochineal.map under fonts\map\dvips\cochineal and both newtx.map and zmn.map under fonts\map\dvips\newtx. I also did run the updmap command in the prompt after installing both fonts.

Here's an example of a small document which produces the error.




\( Test \)


Maybe it's something quite obvious, but I'm really lost. How to get LaTeX to find the .tfm files?

  • Welcome to TeX SX! Probably the postscript fonts names database was not refreshed. In the Tasks menu of MiKTeX console, try Refresh font map files both as user and as administrator.
    – Bernard
    Nov 18, 2019 at 18:57
  • It fails for me too, also in texlive. I will check. Nov 18, 2019 at 19:15
  • @Bernard thanks! I tried to refresh both the font map files and (I don't know if it could have been useful) the file name database, but unfortunately I still get the same error.
    – Vincent
    Nov 18, 2019 at 19:24
  • if is quite probably a bug in the package. Write a mail to the author, he normally corrects this quite fast. Nov 18, 2019 at 19:27
  • Ok I will do that.
    – Vincent
    Nov 18, 2019 at 19:37

1 Answer 1


I contacted the author of the package, and it was indeed a problem with the version available on CTAN. He sent an update of the Cochineal package, and now everything works fine!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .