1

I installed TexStudio and TexLive. However, when I open TexStudio, it tells me that "No LaTeX distribution was found on your system". What do I need to do to be able to compile a pdf with tex studio? I would also be willing to use something like miktex instead of texlive if that makes it easier. Thank you very much for your help!

7
  • 1
    Usually it should find automatically, but if not, go to Options menu and Configure. Then, fill the path to binaries. In my case I have /usr/local/texlive/2019/bin/x86_64-linux/pdflatex -synctex=1 -interaction=nonstopmode -shell-escape %.tex. Your should be similar.
    – Sigur
    Nov 26, 2019 at 12:31
  • Hi Sigur, I expected to find the "binaries" slot in Options -> Configure -> Build, but I only see Build and View, Default Compiler, Default Viewer, PDF Viewer, Default Bibliography Tool. Should I change one of these or where do I find "binaries"?
    – camileri
    Nov 26, 2019 at 12:40
  • 1
    It should be in Commands tab
    – Sigur
    Nov 26, 2019 at 12:40
  • I can't see it there either. However I noticed that LaTex and PdfLaTex do not have a specified file path in the commands tab. Do I need to change those?
    – camileri
    Nov 26, 2019 at 12:43
  • Yes, like my example.
    – Sigur
    Nov 26, 2019 at 12:45

1 Answer 1

1

You should go to the Settings in TexStudio, then Options -> Build and tick the box "Show advanced options". At the bottom of the window you can set the relative path where TexStudio is looking for the LaTex distribution. With most standard installations this is /usr/local/texlive/2020/bin/x86_64

Depending on your operating system and the year of your Latex distribution the year and the x86... part may be different.

PS: This is basically Sigur's answer from the comments with the important addition that you need to tick the "show advanced options" box.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .