1

Since using Catalina (under zsh) finding of files takes a lot more time than before. Example

michaelhoppe@iForst ~ % time kpsewhich inputenc.sty 
/usr/local/texlive/2019/texmf-dist/tex/latex/base/inputenc.sty
kpsewhich inputenc.sty  0,69s user 0,79s system 98% cpu 1,503 total

Even worse:

michaelhoppe@iForst ~ % time kpsewhich pdftex      
kpsewhich pdftex  1,62s user 1,28s system 99% cpu 2,920 total

What's going wrong here? Compilation is fast, but not finding files.

6
  • 1
    Switching to Catalina did not really change these times on my Mac, I think. However, once I had inadvertently two different LaTeX installations on my Mac. This had an effect similar to the one you describe. Can you rule out that you have put another TeX installation on your machine? – user194703 Nov 28 '19 at 15:47
  • Only TeXLive from 2012 to 2019, but only the latter is active, controlled via TLU. – Michael Hoppe Nov 28 '19 at 16:14
  • Under bash on Mojave I get real 0m0.143s, user 0m0.133s, sys 0m0.007s for $ time kpsewhich inputenc.sty. I still use bash under Catalina but if I run $ zsh -l to get a login zsh and run the command I get ` 0.13s user 0.01s system 97% cpu 0.146 total` which isn't very different. – Herb Schulz Nov 28 '19 at 16:57
  • @MichaelHoppe good that you solved your issue. Because this is a Q&A-site the idea is to put questions and answers separately. If you want you can post an answer to your own question with the cause of the problem and the method you used to find this cause. This may be useful for future visitors so it has a place on the site. After posting an answer you can remove the solution part from your question. – Marijn Nov 28 '19 at 18:21
  • 3
    I'm voting to close this question as off-topic because the issue was due to a specific problem in the OP's file system. – egreg Nov 28 '19 at 18:25
1

SOLVED: Found the culprit: somehow a folder containing 70.000 non-TeX-related files found its way in my texhome. kpsewhich -debug=1 did the job.

Thank you all.

Not the answer you're looking for? Browse other questions tagged or ask your own question.