1

I'm using parallel footnotes in my document. Out of the box, it looks great:Footnote-sized footnotes, regular spacing However, I want to reduce the footnote size to \tiny. Easy enough with this command: \renewcommand\footnotesize{\tiny}

When I do this, the footnotes do indeed appear tiny, but the line spacing (line-height?) is retained from \footnotesize, making them look double spaced, and failing to achieve the intended spacing savings. See: Excess spacing in footnotes

I have experimented with no luck in trying to use the setspace package to apply just to the footnotes region. Also, I would like to avoid having to inject something into each footnote, preferring to define something upfront and have it apply globally.

Here's a minimal working example:

\documentclass[twoside,a5paper,6pt]{book} 
\usepackage[T1]{fontenc}
\usepackage{palatino}
\usepackage{lipsum}  
\usepackage{setspace}  
\usepackage[margin=0.5in]{geometry}
\usepackage[para,hang]{footmisc}

\begin{document}

\section{Regular Footnotes, Regular Spacing}
\lipsum[1]\footnote{Small footnote 1}
\lipsum[2] \footnote{Small footnote 2} 
\lipsum[3]\footnote{Small footnote 3}  
\lipsum[4]\footnote{Long footnote: \lipsum[5]}  

\newpage
\renewcommand\footnotesize{\tiny\par}%How to make the line height/spacing \tiny as well?
\section{Small Footnotes, but Regular Spacing}
\lipsum[1]\footnote{Small footnote 1}
\lipsum[2] \footnote{Small footnote 2} 
\lipsum[3]\footnote{Small footnote 1}  
\lipsum[4]\footnote{Long footnote \lipsum[5]\par}  

\end{document}  
3
  • Welcome to TeX.SE. – Mico Nov 29 '19 at 21:37
  • I've taken the liberty of editing your posting and copying the externally stored material into the body of the query. – Mico Nov 29 '19 at 21:41
  • Off-topic: the document class option 6pt has no effect when used with the book document class. The only fontsize-related options that the article, report, and book classes know about are 10pt (the default), 11pt, and 12pt. – Mico Nov 29 '19 at 21:42
1

The package footmisc introduces the \footnotebaselineskip and sets it to the baselineskip in \footnotesize. Also \footnotesep should be changed.

\documentclass[twoside,a5paper]{book}
\usepackage[T1]{fontenc}
\usepackage{newpxtext}
\usepackage[margin=0.5in]{geometry}
\usepackage[para,hang]{footmisc}
\usepackage{etoolbox}

\usepackage{lipsum}

\makeatletter
\patchcmd{\@footnotetext}{\footnotesize}{\tiny}{}{}
\makeatother

\AtBeginDocument{%
  \begingroup\tiny
  \global\footnotesep=0.7\baselineskip
  \global\footnotebaselineskip\baselineskip
  \endgroup
}


\begin{document}

\section{Regular Footnotes, Regular Spacing}
\lipsum[1]\footnote{Small footnote 1}
\lipsum[2] \footnote{Small footnote 2}
\lipsum[3]\footnote{Small footnote 3}
\lipsum[4]\footnote{Long footnote: \lipsum[5]}

\end{document}  

enter image description here

I recommend newpxtext rather than palatino.

1
  • This worked! Thank you! – KC Kern Nov 29 '19 at 22:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.