1

I am trying to install a package with MiKTeX to use with LyX editor on Ubuntu 18.04.

It seems MiKTeX put packages in one directory and LyX reads from another.

How can I resolve it?

3
  • how can I resolve it?
    – Yuval Amit
    Commented Dec 1, 2019 at 13:00
  • Welcome to TeX.SX! Have you tried matching those paths? What have you tried so far? Have you read this post?
    – jchd
    Commented Dec 1, 2019 at 14:05
  • Hi, I am really thankful for you trying to help. I read this post, but wasn't able to get help from it. I am very new to linux, miktex and lyx. I tried to change folder path from within Lyx, but i didn't succeed.
    – Yuval Amit
    Commented Dec 1, 2019 at 18:40

2 Answers 2

1

Have you tried to check the paths known to Lyx. You can do so in Tools > Preferences > Path > PATH prefix enter image description here

Then probably you have to click the Recongigure menu (Tools > Reconfigure) and then re-start Lyx.

I hope that helps.

2
  • Thanks, I tried it and it didn't work, I also see the files in the Tex information. Meanwhile I switched to Texmaker, works perfect
    – Yuval Amit
    Commented Dec 5, 2019 at 20:14
  • 1
    Hello. You might find more information about what is going wrong in the Messages pane. View menu > Messages pane, and then try to compile the document again. Commented Dec 6, 2019 at 21:28
0

Have you installed MiKTeX before installing LyX? The ideal procedure is first to install the latex distribution, such as MiKTeX, and only after LyX, TeXstudio or other software based on latex.

Given that you already have MiKTeX, a simple solution might be obtained by removing the current installation of LyX and installing it again.

During the installation, LyX will ask you to confirm the path of the latex files. You can then confirm and it should work fine afterwards.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .