1

The dateaccessed column won't appear in my .bib file on Overleaf when I import it with Mendeley.

I am using both the web app and desktop version of Mendeley. I tried to go View - Citation style - More styles... and changing the "include URLs and Date accessed in Bibliographies" setting from "For all document types" to "only for webpages". But toggling this setting did not change anything.

When I chose "copy as BibTeX entry" on a reference in Mendeley where the date is registered; the info in the Date Accessed column is included as the entry "urldate". But I can't find the column anywhere in my .bib-file on Overleaf.

I'm importing biblatex like this

\usepackage[style=nature,isbn=false,doi=true,sorting=none]{biblatex}

The image below shows that there is info in the "Data Accessed" column in Mendeley, but the information is not transferred to the .bib file overleaf imports from Mendeley. The Mendeley program clearly has a "Date Accessed" column that is filled. But the info does not appear in the .bib file imported from mendeley

  • Hello there! Tom from Overleaf Support Team here. Can you please reach me on Overleaf support email address, so that we can see what's going on there? Then if it's something worth sharing with others, I will make an answer here. Thanks! – yo' Dec 2 '19 at 14:32
  • I'm not sure if you are asking about the dateaccessed field actually appearing in your .bib file or about the access date appearing in the bibliography output produced by biblatex. If it's the latter you should note that dateaccessed is not a field known by standard biblatex, so if you want to have an access date you need to remap it to urldate and need to make sure that the input is in the right format (IISO 8601). – moewe Dec 2 '19 at 17:19
  • @moewe I saw that my original question was not clear enough and edited it. The problem is that the info in the "Date Accessed" field is not transferred when I import the .bib file to overleaf through Mendeley. If I were to chose "copy as bibtext entry" in Mendely, the info in "Date Accessed" field is copied as "urldate". – Aslak Todal Dec 3 '19 at 11:08
  • I see. In that case that is not a biblatex issue but a general Mendeley/Overleaf exporting issue, so I removed the tag. – moewe Dec 3 '19 at 17:14
1

I have now been in contact with both Overleaf and Mendeley support. It seems like the Mendeley API does not provide all the fields that are expected and @urldate is one of them. It also seems like Mendeley is not prioritizing to fix this any time soon.

Fortunately, with the help of overleaf support team, I did find a solution to the problem.

One of the fields that are provided is "publications", which is transferred to the .bib file as @booktitle. Since most webpages don't have book titles, this can be exploited by copy-pasting the date accessed into the "publications" field and using BibLaTeX-settings that displays the @booktitle field for @misc entries.

| improve this answer | |
  • wow I am having the same problem and this makes Mendeley pretty much useless for me. do you have a link to a bugreport or any follow up on this? – Yush0 Feb 25 at 2:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.