1

I have a project with one main.tex file and several *.tex-files stored in a subfolder called "chapters".

My problem is that in one of the chapter files, say chapter-1.tex, I'm trying to insert a graph with the following code:

\begin{sidewaysfigure}
    \digraph[scale=0.5]{abc}{
            rankdir=LR; a->b->c
            a [label=<foo<SUP>bar</SUP>>];
    }
\end{sidewaysfigure}

I have:

(1) Included the package \usepackage[pdf]{graphviz}

(2) Added a latexmkrc with $pdflatex = 'pdflatex --shell-escape'; that is in the root folder with main.tex.

I have a suspicion that Overleaf is not reading my latexmkrc at all. I tested it by altering the timezone ($ENV{'TZ'}='Europe/Zurich';) but none of the \currenttime labels showed the time of the timezone specificed in my latexmkrc (zurich). I even tried to insert a \currenttime in my main file, but that did not show the Zurich time either.

Here is an excerpt of my main file:

\documentclass[runningheads]{llncs}
\usepackage{amsmath}
\usepackage{amssymb}
\usepackage{datetime}
\usepackage{graphicx}
\usepackage[pdf]{graphviz}

\input{chapters/chapter-1.tex} % In here is the \digraph figure
\input{chapters/chapter-2.tex}

\end{document}

I'm using Overleaf and have followed this guide: Overleaf.

Question

Why am I still getting the "The file abc.pdf hasn’t been created from abc.dot yet. [...]" error when compiling my document? And why isn't overleaf registering my custom latexmkrc file?

1
  • Hello there! Tom from Overleaf Support Team here. I don't know what could cause this. But you can reach me on Overleaf support email address and we can see what's going on there. Then if it's something worth sharing with others, I will make an answer here.
    – yo'
    Dec 4, 2019 at 12:06

1 Answer 1

2

(Tom from Overleaf Support here.)

Mostly -shell-escape calls fail if the main document is not in the root folder of the Overleaf project. The same goes for latexmkrc which has to be always placed in the root folder in order to have any effect. Also, note that -shell-escape is enabled by default in Overleaf; there is no need for latexmkrc for these.

1
  • Hi Tom! Thank you for your support, it worked. I had all my files in a root "Project"-folder. Moving all files out of that folder solved the problem. I am still experiencing some troubles with the graphviz package though, but I'll investigate this a bit more on my own. Thanks again.
    – EmmaA
    Dec 5, 2019 at 15:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.