1

Makeindex with option-s *.ist does not print the indexes. What do options=* mean? Is any command that allows me to colour the entries of the index? I use TexWorks with Miktex. Thanks for your help.

\documentclass{book}
\usepackage{imakeidx}

\makeindex[name=one,title=Index One, intoc, options= -s one.ist]
%\makeindex[name=one,title=Index One, intoc]
\makeindex[name=four,title=Index Four, intoc, options= -s four.ist]
%\makeindex[name=four,title=Index Four]
\makeindex[name=six,title=Index Six, intoc, options= -s six.ist]
%\makeindex[name=six,title=Index Six]

\usepackage[hangindent=0pt,subindent=0pt,subsubindent=0pt]{idxlayout}

\begin{document}

Some text.

\index[one]{Acts of the Avocados!2:2}
\index[one]{Acts of the Avocados!5:5}
\index[one]{Acts of the Avocados!3:3}
\index[one]{Acts of the Avocados!5:5}
\index[one]{Acts of the Avocados!6:6}
\index[one]{Acts of the Avocados!7:7}
\index[one]{Acts of the Avocados!8:8}
\index[one]{Romaines!3:3}
\index[one]{Romaines!4:4}
\index[one]{Romaines!5:5}
\index[four]{Aristotle!Metaphysalis!205c}
\index[four]{Aristotle!Metaphysalis!306d}
\index[four]{Plato!Tomatoes!407e}
\index[four]{Cicero!Lettuce!115}
\index[six]{Bananerges}
\index[six]{Appleadorus}
\index[six]{Plato}
\index[six]{Plato!\textit{Potatoes}!144a}
\index[six]{Plato!\textit{Potatoes}!166d}

\printindex[one]
\printindex[four]
\idxlayout{itemlayout=abshang} 
\printindex[six]
\end{document}
  • Do you supply files one.ist, four.ist and six.ist? Because that's what you are telling makeindex to use to style your indexes. – cfr Dec 6 '19 at 2:05
1

options=-s XXX.ist tells makeindex to use the index style specified in XXX.ist. Unless this is a standard file, you need to supply it. If you don't mean to specify tailored styles for each index, just drop this from the options. The indexes are then created just fine.

\makeindex[name=one,title=Index One, intoc]%, options= -s one.ist]% or supply style in file one.ist
\makeindex[name=four,title=Index Four, intoc]%, options= -s four.ist]
\makeindex[name=six,title=Index Six, intoc]%, options= -s six.ist]
|improve this answer|||||
  • I create three files with *.ist extension with window editor and can't get the output. – Houda Araj Dec 6 '19 at 14:14
  • @HoudaAraj Well, what is in those files? You need to include their content in your question. – cfr Dec 6 '19 at 16:09
  • These are the content of the three files.one.ist heading_prefix "\n\\noindent\\textbf{" heading_suffix "}\\par\\nopagebreak\n" headings_flag 1 four.ist heading_prefix "\n\\noindent\\textbf{" heading_suffix "}\\par\\nopagebreak\n" headings_flag 1 six.ist heading_prefix "\n\\noindent\\textbf{" heading_suffix "}\\par\\nopagebreak\n" headings_flag 1 – Houda Araj Dec 7 '19 at 18:47
  • @HoudaAraj You need to add that information to your question since the problem doesn't occur without those files. – cfr Dec 7 '19 at 19:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.