2

I am running a file in LaTeX (through TeX Live with Notepad++ editor) it is having error; when I am entering the errorstopmode e on the console the TeX file is not opening in the editor, but I want to open in NotePad++ to the error line, how to change the default editor from LaTeX?

4
  • tex.stackexchange.com/questions/305062/… perhaps?
    – Joseph Wright
    Dec 6, 2019 at 10:20
  • For example, on Windows if I do set TEXEDIT=texworks --position=+%d "%s, I get TeXworks opening as requested
    – Joseph Wright
    Dec 6, 2019 at 10:22
  • @Joseph Wright, I had tried, and changed to notepad++ in the TEXEDIT its creating a new file ``-position=+4" and opening this file in the notepadd++, not going in the compiled file
    – pdy_tam
    Dec 6, 2019 at 10:28
  • I guess you need to know what the right arguments are for Notepad++: that's off-topic here ...
    – Joseph Wright
    Dec 6, 2019 at 10:43

1 Answer 1

2

You need to set TEXEDIT, either in texmf.cnf or perhaps easier by setting the appropriate environmental variable. The latter can be done for testing at the command line

set TEXEDIT="<path>\notepad++.exe" -n%d %s

then fixed more permanently using the Control Panel.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.