2

All of a sudden (probably after LaTeX upgrade today) the line \usepackage{fourier} causes the following compilation error: ! I can’t find file ‘FourierOrns’. Hint: I am using XeTeX without changing anything than the upgrade today.

A MWE is:

\documentclass[10pt,article]{memoir}
\usepackage{fourier}

\begin{document}

test

\end {document}

I tried also what has been suggested below to reinstall the fourier package; same problem. This is the .log file.

4
  • 1
    Try: sudo tlmgr install fourier --reinstall
    – NVaughan
    Dec 8 '19 at 19:47
  • 4
    Show a small, complete example that can be used for tests. Dec 8 '19 at 20:10
  • Just a stab in the dark. Do you happen to have a second, older, version of the fourier package? Dec 8 '19 at 20:44
  • I edited the post to reflect the suggested commented above. Dec 8 '19 at 21:50
3

The latest version of the fourier package added a OpenType version of the Fourier Ornament font. Sadly, this font is loaded by font name and not by filename, so XeTeX can not find the font if it is not installed as system font.

The easiest fix is to use LuaLaTeX instead of XeLaTeX or to wait for another update of fourier which fixes this issue. If you want to continue using XeLaTeX, you can also help fontspec find the right font by creating a .fontspec file which maps the name to filenames:

Create a file FourierOrns.fontspec in a directory where TeX can find the file (e.g. the directory of your LaTeX document or under ~/texmf/tex/latex/) with the content

\defaultfontfeatures[FourierOrns] {
  Extension = .otf,
  UprightFont = *-Regular,
  BoldFont = *-Bold,
  ItalicFont = *-Italic,
  BoldItalicFont = *-BoldItalic,
}

This tells fontspec that the font FourierOrns can be found in files named FourierOrns-Regular.otf, FourierOrns-Bold.otf, etc.

After creating this file, fourier works again under XeTeX.

1
  • Wonderful; thanks so much Marcel. Very crisp and up-to-the-point reply. The problem is solved. Regarding LuaLaTeX vs. XeLaTeX, the former was my choice a couple of years ago. However, since I write both Arabic and English in the same document, LuaLaTeX still has some glitches. It did not work with me out of the box like XeLaTeX. Dec 10 '19 at 21:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.