1

I've been typing a document for a few months now and I'm using the class scrreprt. I've just noticed that the header font, which used to be sans serif, has reverted back to serif because the koma font "pageheadfoot" is not taking the \sffamily command (and neither \ttfamily). I reduced the problem to this MWE:

% !TeX TS-program = lualatex
% !TeX encoding = UTF-8
% !TeX spellcheck = it_IT

\documentclass{scrbook}

\usepackage{polyglossia}
\setmainlanguage{italian}

\usepackage{scrlayer-scrpage}
\setkomafont{pageheadfoot}{\sffamily \bfseries}
\KOMAoptions
  { headsepline=on }
\ohead
  { \headmark }
\ofoot*
  { \pagemark }

\usepackage{lipsum}

\begin{document}
\pagestyle{scrheadings}
\chapter{Chapter 1}
\section{Section 1}
\lipsum[1-5]
\section{Section 2}
\lipsum[6-9]
\section{Section 3}
\lipsum[10-12]
\end{document}

However the output is what you can see here:

MWE

UPDATE - I've figured a workaround by putting \sffamily within \markboth and \markright... I don't know whether it is "clean" or "cheating" though.

0

I cannot see it with an up-to-date TL2019:

 *File List*
 scrbook.cls    2019/10/12 v3.27 KOMA-Script document class (book)
scrkbase.sty    2019/10/12 v3.27 KOMA-Script package (KOMA-Script-dependent basi
cs and keyval usage)
 scrbase.sty    2019/10/12 v3.27 KOMA-Script package (KOMA-Script-independent ba
sics and keyval usage)
  keyval.sty    2014/10/28 v1.15 key=value parser (DPC)
scrlfile.sty    2019/10/12 v3.27 KOMA-Script package (loading files)
tocbasic.sty    2019/10/12 v3.27 KOMA-Script package (handling toc-files)
scrsize11pt.clo    2019/10/12 v3.27 KOMA-Script font size class option (11pt)
typearea.sty    2019/10/12 v3.27 KOMA-Script package (type area)
polyglossia.sty    2019/10/27 v1.45 Alternative to Babel for XeLaTeX and LuaLaTe
[...]

enter image description here

|improve this answer|||||
  • Two questions... How can I produce this file list? Is it enough to remove and re-install the KOMA packages from TL Manager to fix eventual broken installations? – TeoFed89 Dec 9 '19 at 17:20
  • add \listfiles as first line into your document and then you'll get the list at the end of the log file. If you have TeXLive then a tlmgr --self --all update seems to be the best. – user187802 Dec 9 '19 at 17:26
  • I see that the difference with what you posted is polyglossia.sty 2019/11/15 v1.46 so this indeed linked to the latest update of polyglossia. Then this question can be marked as duplicate... Thank you nonetheless! – TeoFed89 Dec 9 '19 at 18:54
  • I have a newer polyglossia. – Ulrike Fischer Dec 9 '19 at 19:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.