5

In TeXShop v4.44 on a Mac, hitting Command + F brings up a narrow window on top of the input without giving me the choice to do a case-sensitive search. In older versions, Command + F opened a separate panel with a check box to ignore the case. How do I get this feature back? (I don't know if this is related, but I have switched recently to a single window for input and output and don't know how to switch back.)

1
  • Welcome to TeX.SE. There is a Ignore Case button the Find panel, but don't know if the single window issue is for some reason hiding it. In the TeXShop Preview Preferences there is a "Opening Source and Preview" selection at the bottom. You can change that to "Use Seprate Windows" and that should revert back to separate windows. Also, check that you have selected the editor window and not the PDF window when you hit Command + F. Dec 12, 2019 at 10:09

1 Answer 1

5

What you are seeing is the new default for TeXShop, the Apple Find Bar. It DOES have the ability to do a Case Sensitive Find by clicking on the Magnifying Glass at the left side. The Apple Find Bar also supports a simplified form of regex which is not supported with the Apple Find Panel.

If you wish to return to the older Apple Find Panel set it in the Find Panel section of the Source tab in TeXShop->Preferences and re-start TeXShop. You can also choose the Ogrekit Find Panel there which supports powerful regular expressions (regex) but has some problems under Mojave and later, especially in Dark Mode.

3
  • Thank you so much, Herb Schulz. This does indeed solve my problem. The obsessive quest for minimalism sometimes drives me nuts :) Dec 13, 2019 at 21:33
  • @GeraldKaiser: You can switch to Separate Windows for a document session under the Windows Menu. To change the default look under the Preview tab in TeXShop->Preferences. Dec 14, 2019 at 13:30
  • Thanks again, Herb Schultz. All is well now. Dec 14, 2019 at 21:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .