I am new with LaTeX. I was trying to prepare a presentation with beamer package. However, the error that

Package ifluatex Error: Name clash, \ifluatex is already defined

appears whenever I try to run. Btw, on my computer at work even though I use the same file, there is no such a problem. I saw that I may need to update the MiKTeX Console both as a user and an admin, which I did. The problem still remains. Also, I realize that under the packages ifluatex does not appear. I figured if I manage to install that package there manually, I may solve the problem. I would be more than glad if you can help me.

  • 3
    you have not updated. That error only comes from the old version of the package. If you showed a small test file that makes the error and the log file someone would show you where the old luatex.sty is installed on your system. (you need to update the iftex package (the latex iflluatex package is distributed as part of iftex, not as a separate miktex installation package) Dec 13, 2019 at 16:33
  • Thank you for your response. I tried to update iftex package in the miktex console. But it did not work. I am not sure what did you mean by test file, but this is what appears at the bottom when I hit the execute button: "Package ifluatex Error: Name clash, \ifluatex is already defined. } pdflatex.exe (file ./IV_6.pdf): PDF inclusion: found PDF version <1.6>, but at most version <1.5> allowed<IV_6.pdf, id=295, 397.485pt x 289.08pt>File: IV_6.pdf Graphic file (type pdf)<use IV_6.pdf>Package pdftex.def Info: IV_6.pdf used" Dec 15, 2019 at 8:21
  • 1
    That just means you have the old copy of ifluatex package installed which you should not have. By a test file I mean a small complete document that gives that error and show the full lo file that you get Dec 15, 2019 at 13:53

2 Answers 2


In TeX Live, you can update to the newest version of ifluatexm by running tlmgr with the command install --reinstall iftex. If you have an older version of ifluatex, you might want to uninstall it manually, or run update --self --all.

You need to run it as whatever account owns your TeX tree. Since I installed as a system account named tex, the command I would use is:

sudo -u tex $(which tlmgr) install --reinstall iftex

For new code, the package iftex replaces ifluatex and its brethren.


I ran into a similar problem, and I simply went to the file directory where ifluatex.sty was located, renamed it as ifuatex_copy.sty (or anything else will suffice I suppose), uninstalled the iftex package from the MikTex console, then reinstalled it. Running smoothly now!

  • 1
    I updated MiKTex 2.9 today (Jan. 20, 2020) and then I received the error message mentioned above: The solution by lascooter worked perfectly. Thanks!
    – user205361
    Jan 22, 2020 at 15:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .