1

For the shown MWE, the [easylist] package is working fine with the default language of the document which is set to "Arabic" language, however upon using other language "English", the bullets are correct but the indentation is lost.


\documentclass[a4paper,12pt,twoside]{book}
\usepackage[a4paper,top=2.5cm,bottom=2.5cm,margin=2.5cm,bindingoffset=0.5cm]{geometry} 

\usepackage[hidelinks,colorlinks=true,breaklinks,allcolors=blue]{hyperref} 

\usepackage[bidi=basic,layout=lists.tabular]{babel}
\babelprovide[import=ar,mapdigits,main]{arabic}
\babelprovide[import=en,language=Default]{english}

\babelfont{rm}{Latin Modern Roman}
\babelfont[arabic]{rm}{Simplified Arabic}
\babelfont[english]{rm}{Times New Roman}

\usepackage{enumitem}
\setlistdepth{9}
\setlist[itemize,1]{label=$\bullet$}
\setlist[itemize,2]{label=$\bullet$}
\setlist[itemize,3]{label=$\bullet$}
\setlist[itemize,4]{label=$\bullet$}
\setlist[itemize,5]{label=$\bullet$}
\setlist[itemize,6]{label=$\bullet$}
\setlist[itemize,7]{label=$\bullet$}
\setlist[itemize,8]{label=$\bullet$}
\setlist[itemize,9]{label=$\bullet$}
\renewlist{itemize}{itemize}{9}
\setlist[itemize]{noitemsep, topsep=0pt} 

\usepackage[at]{easylist}
        \ListProperties(
                Progressive*=3ex,
                Space=5pt,
                Space*=5pt,
                Style1*=\textbullet\ \ ,
                Style2*=\begin{normalfont}\begin{bfseries}\textendash\end{bfseries}\end{normalfont} \ \ ,
                Style3*=\textasteriskcentered\ \ ,
                Style4*=\textperiodcentered\ \ ,
                Style5*=\textbullet\ \ ,
                Style6*=\begin{normalfont}\begin{bfseries}\textendash\end{bfseries}\end{normalfont}\ \ ,
                Style7*=\textasteriskcentered\ \ ,
                Style8*=\textperiodcentered\ \ ,
                Hide1=1,
                Hide2=2,
                Hide3=3,
                Hide4=4,
                Hide5=5,
                Hide6=6,
                Hide7=7,
                Hide8=8 )
\usepackage[table]{xcolor}
\usepackage{tabu,multirow}
\usepackage{array}
\newcolumntype{?}[1]{!{\vrule width #1}}
\usepackage{booktabs}




\title{jhhjjhhj}
\author{}
\date{}

\begin{document}
\chapter{شكر وتقدير} 
\begin{easylist}
@ يبيسبسيبيسب
@@ سيبسيبسيبسيب
@@@ سيبسيبسيبسيبسيب
@@@@ سيبسيبسيبسيبسيب
@@@@@ سيبسيبسيبسيبسيبسيب
@@@@@@ سيبسيبيسبسيبسيبسيبسيب
\end{easylist}
\begin{otherlanguage}{english}
\begin{easylist}
@ qwewqewqe
@@ qwewqewqe
@@@ qwewqewqe
@@@@ qwewqewqe
@@@@@ qwewqewqe
@@@@@@ qwewqewqe
\end{easylist}
\end{otherlanguage}
\end{document}


Output

2
  • Did you try to use paracol?
    – user194703
    Dec 14, 2019 at 21:08
  • @ Schrödinger's cat, I never heard about it.
    – Silva
    Dec 15, 2019 at 0:31

1 Answer 1

1

Try with:

\begin{otherlanguage}{english}
\shapemode1
\begin{easylist}
@ qwewqewqe
@@ qwewqewqe
@@@ qwewqewqe
@@@@ qwewqewqe
@@@@@ qwewqewqe
@@@@@@ qwewqewqe
\end{easylist}
\end{otherlanguage}

The LuaTeX parameter \shapemode controls how \hangindent and \hangafter behave in bidi contexts, which are used by easylist. babel adds this parameter to some internal macros, including standard lists, but not to packages (enumitem relies on the LaTeX \list, so it works out the box).

By the way, don't use \babelprovide for languages supported in the standard way as class or package options, except if there is a reason to prefer not to load them.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .