2

I am using Lyx 2.2.4 supported by Linux Mint 19.2. I have Hunspell dictionaries loaded in usr/share/hunspell but they are not recognised by Lyx. Preference/paths/Hunspell is greyed out and I cannot load the path. I have checked out the info in wiki.lyx.org/Devel/Hunspell#toc3 and as far as I can see everything is OK. I've uninstalled, reinstalled, reconfigured etc but to no avail. Help with this would be much appreciated

2
  • What does you setting for 'alternate language' say? Here I had a similar problem because of a messed up setting there. With \alternate_language "en" in my ~/.lyx/preferences it works with spellchecker at GUI set to enchant, and hunspell dicts installed.
    – Jaleks
    Commented Jun 7, 2020 at 14:23
  • I am having the same problem and this didn't work for me, the box for Hunspell's path is still greyed out!?
    – Matifou
    Commented Oct 22, 2022 at 8:56

1 Answer 1

1

It's a configuration issue. If LyX has not been compiled with --use-hunspell, then Hunspell support is disabled. You can either compile yourself or ask your packager to provide a version with hunspell support.

1
  • oh too bad to hear it is so complicated, but thanks for the answer!! :-)
    – Matifou
    Commented Oct 23, 2022 at 18:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .