2

I'm attempting to write a document with a full IEEE citation in a footnote, using biblatex following this question: revtex 4-1: Writing a full citation in footnote. A minimal version of my tex is:

\documentclass{article}
% just to make a small output for this test
\usepackage[paperwidth=2in,paperheight=1in]{geometry}
\usepackage{polyglossia}
\setdefaultlanguage{english}
\usepackage{filecontents}
\begin{filecontents}{test.bib}
@incollection{paper,
title = {Paper Title},
author = {cwindolf},
booktitle = {Book},
editor = {Editors},
pages = {1},
year = {2019},
publisher = {TeX.SE},
url = {tex.stackexchange.com}
}
\end{filecontents}
\usepackage{microtype}
\usepackage[backend=bibtex,citestyle=verbose-ibid,style=ieee]{biblatex}
\addbibresource{test.bib}
\usepackage[hidelinks]{hyperref}
\begin{document}
Um \footcite{paper}.
\end{document}

which produces the not-so-great output:

enter image description here

If I get rid of the style=ieee, the citation does show up in the footnote:

enter image description here

I'm wondering if there's any way to do this in IEEE style. Thanks!

1
  • With citestyle=verbose-ibid, bibstyle=ieee, you should get IEEE style in the footnote on first citation, but subsequent citations of the same work will use a shortened author-title scheme. You could switch to full style=ieee, and use \footfullcite...
    – moewe
    Commented Dec 17, 2019 at 7:09

1 Answer 1

2

Building on moewe's suggestion, I found an acceptable solution by setting my default citation style for \autocite{} to use \footfullcite{}.

% preamble
\usepackage[style=ieee,autocite=footnote]{biblatex}
% Redefine the footnote style we specify as a default for autocite
\DeclareAutoCiteCommand{footnote}{\footfullcite}{\footfullcite}
% Use semicolon as a delimiter to partially support (NOT FULLY) \autocites
\renewcommand\multicitedelim{\addsemicolon\space}
% ...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .