1

I am trying to convert a DVI to SVG on Manjaro / Arch Linux, but it just won't work.

I use the following latex (test.tex) to create a dvi file (test.div)

\documentclass{standalone}
\usepackage{tikz}

\begin{document}
\begin{tikzpicture}
  \def\r{2cm}
  \node (O) at (0,0) {$O$};
  \draw (0,0) circle (\r);
  \draw[->] (-\r,0)--(\r,0);
  \draw[->] (0,-\r)--(0,\r);
\end{tikzpicture}
\end{document}

Compile test.tex to dvi with the command line below:

latex test.tex

Create an SVG from the created test.div file.

dvisvgm test.dvi

Now I get the following error message:

pre-processing DVI file (format version 2)

 *** WARNING - you have selected SAFER, indicating you want Ghostscript
               to execute in a safer environment, but at the same time
               have selected DELAYBIND. Unless you use this option with
               care (and specifically, remember to call .bindnow) it is
               possible that malicious code may be able to evade the
               limited security offered by the SAFER option.

 *** WARNING - you have selected SAFER, indicating you want Ghostscript
               to execute in a safer environment, but at the same time
               have selected WRITESYSTEMDICT. Unless you use this option with
               care and specifically, remember to execute code like:
                      "systemdict readonly pop"
           processing page 1
  PostScript error: undefined in get
  Operand stack:
      --nostringval--  --nostringval--  --nostringval--  --nostringval--  --nostringval--  1  1  --nostringval--  .setopacityalpha

Ghostscript is installed.

3
  • 2
    You probably use Ghostscript 9.50 together with a dvisvgm version < 2.8.Older versions of dvisvgm don't work with the latest GS due to incompatible changes of the latter. You either must update dvisvgm or downgrade Ghostscript to get rid of the mentioned PostScript errors.
    – Martin
    Commented Dec 21, 2019 at 20:46
  • You're right, my dvisvgm version is 2.6.3. Thank you!
    – swap
    Commented Dec 22, 2019 at 10:02
  • You're welcome. :-)
    – Martin
    Commented Dec 22, 2019 at 16:39

0

You must log in to answer this question.

Browse other questions tagged .