2

I have created a table expanding to whole width of the page, using table*. After this table, I have created another table only with table command. The second table is not appearing in the document. The latex code for the first table as below

\begin{table*}[]
\small
\begin{tabular}{ll}
\hline
Error & Number \\
\hline
error1 & 11 \\
\end{tabular}
\end{table*}

The latex code for the second table as below

\begin{table}[]
\begin{tabular}{lll}
\hline
Error    & Error Sequence \\
\hline
Naming Error & 2  \\
\end{tabular}
\end{table}

Can anyone suggest how to make the second table to appear in the document ? Thank you

6
  • 1
    Welcome to TeX SX! Where's your \begin{table(*)}?
    – Bernard
    Commented Dec 28, 2019 at 22:55
  • Hi @Bernard That's the first table I have indicated. \begin{table*}[] This is getting displayed at the top of the next page.
    – YatShan
    Commented Dec 28, 2019 at 22:57
  • 1
    please post a small but complete document that shows the error. it is impossible to debug code that we can not see. LaTeX should never drop the table without warning, it should be in the output or there should be a warning about "floats lost" in the log file. Commented Dec 28, 2019 at 23:01
  • You should post a compilable code reproducing the problem. You don't even what's your document class, nor whether you have a two-column or single column document.
    – Bernard
    Commented Dec 28, 2019 at 23:01
  • Welcome to TeX.SE! As it is, though, we can't do much more than wildly guess. Please provide a minimal working example with your question; we're all volunteers here, and there's a limited amount of work we're willing to do. Commented Dec 28, 2019 at 23:01

1 Answer 1

2

If you use standard packages, your tables appear in the document. See the following MWE:

enter image description here

\documentclass[twocolumn]{article}
\usepackage{array}
\setlength{\extrarowheight}{1pt}

\begin{document}

I have created a table expanding to whole width of the page, using table*. After this table, I have created another table only with table command. The second table is not appearing in the document. The latex code for the first table as below

\begin{table*}
\small
\caption{Table 1 is here, and you have to load caption to have nice captions}
\begin{tabular}{lcccccc}
\hline
Error & Number & Number & Number & Number & Number & Number \\
\hline
error1 & 11 & 11 & 11 & 11 & 11 & 11 \\
error1 & 11 & 11 & 11 & 11 & 11 & 11 \\
error1 & 11 & 11 & 11 & 11 & 11 & 11 \\
error1 & 11 & 11 & 11 & 11 & 11 & 11 \\
\hline
\end{tabular}
\end{table*}

The latex code for the second table as below.I have created a table expanding to whole width of the page, using table*. After this table, I have created another table only with table command. The second table is not appearing in the document. The latex code for the first table as below

I have created a table expanding to whole width of the page, using table*. After this table, I have created another table only with table command. The second table is not appearing in the document. The latex code for the first table as below

I have created a table expanding to whole width of the page, using table*. After this table, I have created another table only with table command. The second table is not appearing in the document. The latex code for the first table as below

I have created a table expanding to whole width of the page, using table*. 
I have created a table expanding to whole width of the page, using table*. After this table, I have created another table only with table command. The second table is not appearing in the document. The latex code for the first table as below. I have created a table expanding to whole width of the page, using table*. After this table, I have created another table only with table command. The second table is not appearing in the document. The latex code for the first table as below. I have created a table expanding to whole width of the page, using table*. After this table, I have created another table only with table command. The second table is not appearing in the document. The latex code for the first table as below.


\begin{table}[t!]
\caption{Table 2 is here and sometimes there, but never where you expected}
\begin{tabular}{lrr}
\hline
Error    & Error Sequence & Reaction\\
\hline
Naming Error & 2  & 3\\
Naming Error & 2  & 3\\
Naming Error & 2  & 3\\
Naming Error & 2  & 3\\
\hline
\end{tabular}
\end{table}

Can anyone suggest how to make the second table to appear in the document ? Thank you

I have created a table expanding to whole width of the page, using table*. After this table, I have created another table only with table command. The second table is not appearing in the document. The latex code for the first table as below. I have created a table expanding to whole width of the page, using table*. After this table, I have created another table only with table command. The second table is not appearing in the document. The latex code for the first table as below. I have created a table expanding to whole width of the page, using table*. After this table, I have created another table only with table command. The second table is not appearing in the document. The latex code for the first table as below.

I have created a table expanding to whole width of the page, using table*. After this table, I have created another table only with table command. The second table is not appearing in the document. The latex code for the first table as below. I have created a table expanding to whole width of the page, using table*. After this table, I have created another table only with table command. The second table is not appearing in the document. The latex code for the first table as below


I have created a table expanding to whole width of the page, using table*. After this table, I have created another table only with table command. The second table is not appearing in the document. The latex code for the first table as below.

I have created a table expanding to whole width of the page, using table*. After this table, I have created another table only with table command. The second table is not appearing in the document. The latex code for the first table as below. I have created a table expanding to whole width of the page, using table*. After this table, I have created another table only with table command. The second table is not appearing in the document. The latex code for the first table as below. I have created a table expanding to whole width of the page, using table*. After this table, I have created another table only with table command. The second table is not appearing in the document. The latex code for the first table as below.
I have created a table expanding to whole width of the page, using table*. After this table, I have created another table only with table command. The second table is not appearing in the document. The latex code for the first table as below. I have created a table expanding to whole width of the page, using table*. After this table, I have created another table only with table command. The second table is not appearing in the document. The latex code for the first table as below. I have created a table expanding to whole width of the page, using table*. After this table, I have created another table only with table command. The second table is not appearing in the document. The latex code for the first table as below.

I have created a table expanding to whole width of the page, using table*. After this table, I have created another table only with table command. The second table is not appearing in the document. The latex code for the first table as below. I have created a table expanding to whole width of the page, using table*. After this table, I have created another table only with table command. The second table is not appearing in the document. The latex code for the first table as below. I have created a table expanding to whole width of the page, using table*. After this table, I have created another table only with table command. The second table is not appearing in the document. The latex code for the first table as below.
I have created a table expanding to whole width of the page, using table*. After this table, I have created another table only with table command. The second table is not appearing in the document. The latex code for the first table as below. I have created a table expanding to whole width of the page, using table*. After this table, I have created another table only with table command. The second table is not appearing in the document. The latex code for the first table as below. I have created a table expanding to whole width of the page, using table*. After this table, I have created another table only with table command. The second table is not appearing in the document. The latex code for the first table as below.

 The second table is not appearing in the document. The latex code for the first table as below. I have created a table expanding to whole width of the page, using table*. After this table, I have created another table only with table command. The second table is not appearing in the document. The latex code for the first table as below. I have created a table expanding to whole width of the page, using table*. After this table, I have created another table only with table command. The second table is not appearing in the document. The latex code for the first table as below.

 The second table is not appearing in the document. The latex code for the first table as below. I have created a table expanding to whole width of the page, using table*. After this table, I have created another table only with table command. The second table is not appearing in the document. The latex code for the first table as below. I have created a table expanding to whole width of the page, using table*. After this table, I have created another table only with table command. The second table is not appearing in the document. The latex code for the first table as below.

 The second table is not appearing in the document. The latex code for the first table as below. I have created a table expanding to whole width of the page, using table*. After this table, I have created another table only with table command. The second table is not appearing in the document. The latex code for the first table as below. I have created a table expanding to whole width of the page, using table*. After this table, I have created another table only with table command. The second table is not appearing in the document. The latex code for the first table as below.

\end{document}
1
  • @DavidCarlisle Thank you for the edit, I have noticed the comment.
    – Sveinung
    Commented Dec 28, 2019 at 23:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .